summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-sci')
-rw-r--r--app-sci/babel/ChangeLog13
-rw-r--r--app-sci/babel/babel-1.6.ebuild47
-rw-r--r--app-sci/babel/files/10babel1
-rw-r--r--app-sci/babel/files/babel-1.6-gentoo.diff28
-rw-r--r--app-sci/babel/files/digest-babel-1.61
-rw-r--r--app-sci/euler/euler-1.59.1.ebuild4
-rw-r--r--app-sci/gperiodic/gperiodic-1.3.2.ebuild4
-rw-r--r--app-sci/iverilog/Changelog9
-rw-r--r--app-sci/iverilog/files/digest-iverilog-0.6.11
-rw-r--r--app-sci/iverilog/iverilog-0.6.1.ebuild28
-rw-r--r--app-sci/netcdf/ChangeLog13
-rw-r--r--app-sci/netcdf/files/digest-netcdf-3.5.0-r11
-rw-r--r--app-sci/netcdf/netcdf-3.5.0-r1.ebuild40
-rw-r--r--app-sci/octave/ChangeLog11
-rw-r--r--app-sci/octave/files/digest-octave-2.0.161
-rw-r--r--app-sci/octave/octave-2.0.16.ebuild46
16 files changed, 246 insertions, 2 deletions
diff --git a/app-sci/babel/ChangeLog b/app-sci/babel/ChangeLog
new file mode 100644
index 000000000000..a6c2fb7333aa
--- /dev/null
+++ b/app-sci/babel/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-sci/babel
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/babel/ChangeLog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*babel-1.6 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/babel/babel-1.6.ebuild b/app-sci/babel/babel-1.6.ebuild
new file mode 100644
index 000000000000..d405999b93fa
--- /dev/null
+++ b/app-sci/babel/babel-1.6.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod Neidt <tneidt@fidnet.com>
+# $ Header: $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="Babel is a program to interconvert file formats used in molecular modeling."
+
+SRC_URI="http://smog.com/chem/babel/files/${P}.tar.Z"
+
+HOMEPAGE="http://smog.com/chem/babel/"
+
+#Doesn't really seem to depend on anything (?)
+DEPEND="virtual/glibc"
+
+PROVIDE="app-misc/babel"
+
+src_unpack() {
+
+ unpack ${P}.tar.Z
+ cd ${S}
+#Patch the Makefile for gentoo-isms
+ patch -p0 < ${FILESDIR}/${P}-gentoo.diff || die
+
+}
+
+src_compile() {
+
+ emake || die
+
+}
+
+src_install () {
+
+ make DESTDIR=${D}/usr/bin install || die
+
+ insinto /usr/share/${PN}
+ doins ${S}/*.lis
+
+ insinto /etc/env.d
+ doins ${FILESDIR}/10babel
+
+ dodoc README.1ST
+
+}
+
diff --git a/app-sci/babel/files/10babel b/app-sci/babel/files/10babel
new file mode 100644
index 000000000000..69f3397638dd
--- /dev/null
+++ b/app-sci/babel/files/10babel
@@ -0,0 +1 @@
+BABEL_DIR=/usr/share/babel
diff --git a/app-sci/babel/files/babel-1.6-gentoo.diff b/app-sci/babel/files/babel-1.6-gentoo.diff
new file mode 100644
index 000000000000..77e2cb47ef03
--- /dev/null
+++ b/app-sci/babel/files/babel-1.6-gentoo.diff
@@ -0,0 +1,28 @@
+--- Makefile.orig Tue Oct 23 00:20:54 2001
++++ Makefile Tue Oct 23 00:33:36 2001
+@@ -1,11 +1,15 @@
+-CFLAGS = -O
++#Commented out to pull CFLAGS from make.conf
++#CFLAGS = -O
+
+ LIBFLAGS = -O -DLIBRARY
+
+-CC = cc
++#Probably not necessary to specify gcc
++CC = gcc
+
+ PROGRAM = babel
+
++DEST = ${DESTDIR}/$(PROGRAM)
++
+ LDFLAGS =
+
+ LIBS =
+@@ -334,6 +338,7 @@
+ index:; ctags -wx $(HDRS) $(SRCS)
+
+ install: $(PROGRAM)
++ install -d ${DESTDIR}
+ install -s $(PROGRAM) $(DEST)
+
+ print:; $(PRINT) $(HDRS) $(SRCS)
diff --git a/app-sci/babel/files/digest-babel-1.6 b/app-sci/babel/files/digest-babel-1.6
new file mode 100644
index 000000000000..118db2b06dc9
--- /dev/null
+++ b/app-sci/babel/files/digest-babel-1.6
@@ -0,0 +1 @@
+MD5 101a5dc4858ecacac123571db52b272e babel-1.6.tar.Z 242341
diff --git a/app-sci/euler/euler-1.59.1.ebuild b/app-sci/euler/euler-1.59.1.ebuild
index d60e388e5197..e9b4a23e412c 100644
--- a/app-sci/euler/euler-1.59.1.ebuild
+++ b/app-sci/euler/euler-1.59.1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Karl Trygve Kalleberg <karltk@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/app-sci/euler/euler-1.59.1.ebuild,v 1.1 2002/05/07 00:30:27 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/euler/euler-1.59.1.ebuild,v 1.2 2002/05/08 02:04:28 george Exp $
S=${WORKDIR}/${P}
@@ -15,6 +15,8 @@ DEPEND="virtual/glibc
virtual/x11
>=x11-libs/gtk+-1.2"
+PROVIDE="app-misc/euler"
+
src_unpack() {
unpack ${P}.tar.gz
mv euler-1.59 ${P}
diff --git a/app-sci/gperiodic/gperiodic-1.3.2.ebuild b/app-sci/gperiodic/gperiodic-1.3.2.ebuild
index 52e30ff92044..c74ba6225e5c 100644
--- a/app-sci/gperiodic/gperiodic-1.3.2.ebuild
+++ b/app-sci/gperiodic/gperiodic-1.3.2.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License, v2 or later
# Maintainer: Desktop Team <desktop@cvs.gentoo.org>
# Author Tod Neidt <tneidt@fidnet.com>
-# $Header: /var/cvsroot/gentoo-x86/app-sci/gperiodic/gperiodic-1.3.2.ebuild,v 1.1 2002/05/07 01:35:08 george Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-sci/gperiodic/gperiodic-1.3.2.ebuild,v 1.2 2002/05/08 02:04:28 george Exp $
S=${WORKDIR}/${P}
DESCRIPTION="GPeriodic is a periodic table application for Linux."
@@ -13,6 +13,8 @@ DEPEND=">=sys-libs/ncurses-5.2
>=x11-libs/gtk+-1.2.1
nls? ( sys-devel/gettext )"
+PROVIDE="app-misc/gperiodic"
+
src_unpack() {
unpack ${P}.tar.gz
cd ${S}
diff --git a/app-sci/iverilog/Changelog b/app-sci/iverilog/Changelog
new file mode 100644
index 000000000000..99ace8cfe160
--- /dev/null
+++ b/app-sci/iverilog/Changelog
@@ -0,0 +1,9 @@
+# ChangeLog for dev-lang/icarus_verilog
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/iverilog/Changelog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*icarus_verilog-0.6.1 (4/3/2002)
+
+ 3 Apr 2002; Chad Huneycutt <chadh@gentoo.org> icarus_verilog-0.6.1.ebuild :
+
+ Ebuild created
diff --git a/app-sci/iverilog/files/digest-iverilog-0.6.1 b/app-sci/iverilog/files/digest-iverilog-0.6.1
new file mode 100644
index 000000000000..d4bc73f232e4
--- /dev/null
+++ b/app-sci/iverilog/files/digest-iverilog-0.6.1
@@ -0,0 +1 @@
+MD5 908be21238c8e4fd30ecc7c82d7767ad verilog-0.6.1.tar.gz 731502
diff --git a/app-sci/iverilog/iverilog-0.6.1.ebuild b/app-sci/iverilog/iverilog-0.6.1.ebuild
new file mode 100644
index 000000000000..b6ae81cda2ac
--- /dev/null
+++ b/app-sci/iverilog/iverilog-0.6.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-sci/iverilog/iverilog-0.6.1.ebuild,v 1.1 2002/05/08 02:04:28 george Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="A Verilog simulation and synthesis tool"
+SRC_URI="ftp://icarus.com/pub/eda/verilog/v0.6/verilog-${PV}.tar.gz"
+HOMEPAGE="http://www.icarus.com/eda/verilog/"
+DEPEND="dev-util/gperf"
+PROVIDE="dev-lang/iverilog"
+
+src_unpack() {
+ unpack ${A}
+ cd ${WORKDIR}
+ mv verilog-${PV} ${P}
+}
+
+src_install () {
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc *.txt COPYING INSTALL examples/*
+}
+
diff --git a/app-sci/netcdf/ChangeLog b/app-sci/netcdf/ChangeLog
new file mode 100644
index 000000000000..afa0cae46066
--- /dev/null
+++ b/app-sci/netcdf/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for app-sci/netcdf
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/ChangeLog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*netcdf-3.5.0-r1 (1 Feb 2002)
+
+ 1 Feb 2002; G.Bevin <gbevin@gentoo.org> ChangeLog :
+
+ Added initial ChangeLog which should be updated whenever the package is
+ updated in any way. This changelog is targetted to users. This means that the
+ comments should well explained and written in clean English. The details about
+ writing correct changelogs are explained in the skel.ChangeLog file which you
+ can find in the root directory of the portage repository.
diff --git a/app-sci/netcdf/files/digest-netcdf-3.5.0-r1 b/app-sci/netcdf/files/digest-netcdf-3.5.0-r1
new file mode 100644
index 000000000000..25d6e8d0de3d
--- /dev/null
+++ b/app-sci/netcdf/files/digest-netcdf-3.5.0-r1
@@ -0,0 +1 @@
+MD5 28640a40a44f982f90f5eeb15e917a1f netcdf-3.5.0.tar.Z 1319419
diff --git a/app-sci/netcdf/netcdf-3.5.0-r1.ebuild b/app-sci/netcdf/netcdf-3.5.0-r1.ebuild
new file mode 100644
index 000000000000..9941851b9845
--- /dev/null
+++ b/app-sci/netcdf/netcdf-3.5.0-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Tod M. Neidt <tneidt@fidnet.com>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/netcdf/netcdf-3.5.0-r1.ebuild,v 1.1 2002/05/08 02:04:28 george Exp $
+
+S=${WORKDIR}/${P}/src
+DESCRIPTION="Interface for array oriented data access"
+
+#Note orig source archive does not have version # in filename
+#SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${PN}.tar.Z"
+#but most of the mirrors do.
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.Z"
+
+HOMEPAGE="http://www.unidaa.ucar.edu/packages/netcdf/"
+
+DEPEND="virtual/glibc"
+
+PROVIDE="app-misc/netcdf"
+
+src_compile() {
+ export CPPFLAGS=-Df2cFortran
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man || die
+
+ emake || die
+
+ make test || die
+}
+
+src_install() {
+ dodir /usr/{lib,share}
+
+ make prefix=${D}/usr \
+ MANDIR=${D}/usr/share/man \
+ install || die
+
+ dodoc COMPATIBILITY COPYRIGHT INSTALL.html MANIFEST
+ dodoc README RELEASE_NOTES VERSION
+}
diff --git a/app-sci/octave/ChangeLog b/app-sci/octave/ChangeLog
new file mode 100644
index 000000000000..13646e247423
--- /dev/null
+++ b/app-sci/octave/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for <CATEGORY>/<PACKAGE_NAME>
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/ChangeLog,v 1.1 2002/05/08 02:04:28 george Exp $
+
+*octave-2.0.16 (19 Feb 2002)
+
+ 19 Feb 2002; T.Neidt <tod@gentoo.org> ChangeLog, octave-2.0.16.ebuild :
+
+ Initial commit. GNU Octave is a high-level language, primarily intended
+ for numerical computations. It is mostly compatible with Matlab.
+
diff --git a/app-sci/octave/files/digest-octave-2.0.16 b/app-sci/octave/files/digest-octave-2.0.16
new file mode 100644
index 000000000000..e4495104242d
--- /dev/null
+++ b/app-sci/octave/files/digest-octave-2.0.16
@@ -0,0 +1 @@
+MD5 439e8e70706c875149836146d1ccebe0 octave-2.0.16.tar.bz2 3009214
diff --git a/app-sci/octave/octave-2.0.16.ebuild b/app-sci/octave/octave-2.0.16.ebuild
new file mode 100644
index 000000000000..8f768c2e40a7
--- /dev/null
+++ b/app-sci/octave/octave-2.0.16.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tod Neidt <tod@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/app-sci/octave/octave-2.0.16.ebuild,v 1.1 2002/05/08 02:04:28 george Exp $
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="GNU Octave is a high-level language (MatLab compatible) intended for numerical computations."
+
+SRC_URI="ftp://ftp.octave.org/pub/octave/${P}.tar.bz2"
+
+HOMEPAGE="http://www.octave.org/"
+
+DEPEND="virtual/glibc
+ >=sys-libs/ncurses-5.2-r3
+ >=media-gfx/gnuplot-3.7.1"
+
+PROVIDE="dev-lang/octave"
+
+src_compile() {
+
+ local myconf="--enable-shared --enable-dl --enable-lite-kernel"
+
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} || die "./configure failed"
+
+ emake || die
+
+}
+
+src_install () {
+
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ dodoc BUGS COPYING ChangeLog* INSTALL* NEWS* PROJECTS README* ROADMAP \
+ SENDING-PATCHES THANKS
+
+}