summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/enscript/enscript-1.6.3-r3.ebuild')
-rw-r--r--app-text/enscript/enscript-1.6.3-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-text/enscript/enscript-1.6.3-r3.ebuild b/app-text/enscript/enscript-1.6.3-r3.ebuild
new file mode 100644
index 000000000000..28df8f648f91
--- /dev/null
+++ b/app-text/enscript/enscript-1.6.3-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/enscript/enscript-1.6.3-r3.ebuild,v 1.1 2005/01/27 15:58:18 solar Exp $
+
+inherit eutils
+
+DESCRIPTION="powerful text-to-postscript converter"
+SRC_URI="http://www.iki.fi/mtr/genscript/${P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/enscript/enscript.html"
+
+KEYWORDS="~x86 ~ppc ~sparc ~amd64 ~alpha ~mips ~ppc64"
+SLOT="0"
+LICENSE="GPL-2"
+IUSE="nls"
+
+DEPEND="sys-devel/flex
+ sys-devel/bison
+ nls? ( sys-devel/gettext )"
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/enscript-1.6.3-security.patch
+}
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ dodoc AUTHORS ChangeLog FAQ.html NEWS README* THANKS TODO
+}
+
+pkg_postinst() {
+ einfo "Now, customize /etc/enscript.cfg."
+}