summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-text/ispell/ispell-3.2.06-r3.ebuild')
-rw-r--r--app-text/ispell/ispell-3.2.06-r3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-text/ispell/ispell-3.2.06-r3.ebuild b/app-text/ispell/ispell-3.2.06-r3.ebuild
new file mode 100644
index 000000000000..60e235f765f4
--- /dev/null
+++ b/app-text/ispell/ispell-3.2.06-r3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/app-text/ispell/ispell-3.2.06-r3.ebuild,v 1.1 2002/07/12 01:01:11 seemant Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Ispell is a fast screen-oriented spelling checker"
+SRC_URI="http://fmg-www.cs.ucla.edu/geoff/tars/${P}.tar.gz
+ http://www.ibiblio.org/pub/Linux/distributions/gentoo/distfiles/${P}-gentoo.diff.bz2"
+HOMEPAGE="http://fmg-www.cs.ucla.edu/geoff/ispell.html"
+
+DEPEND="sys-devel/bison
+ >=sys-libs/ncurses-5.2"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+
+src_unpack() {
+
+ unpack ${P}.tar.gz
+
+ cd ${S}
+ bzcat ${DISTDIR}/${P}-gentoo.diff.bz2 | patch || die
+
+}
+
+src_compile() {
+ make || die
+}
+
+src_install() {
+
+ #Fix config.sh to install to ${D}
+ cp config.sh config.sh.orig
+ sed \
+ -e "s:^\(BINDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(LIBDIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN1DIR='\)\(.*\):\1${D}\2:" \
+ -e "s:^\(MAN4DIR='\)\(.*\):\1${D}\2:" \
+ config.sh.orig > config.sh
+
+ #Need to create the directories to install into
+ #before 'make install'. Build environment **doesn't**
+ #check for existence and create if not already there.
+ dodir /usr/bin /usr/lib/ispell /usr/share/info \
+ /usr/share/man/man1 /usr/share/man/man5
+
+ make \
+ install || die "Installation Failed"
+
+ rmdir ${D}/usr/share/man/man5
+ rmdir ${D}/usr/share/info
+
+ dodoc Contributors README WISHES
+}