summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-cpp/libglademm/libglademm-2.6.0.ebuild')
-rw-r--r--dev-cpp/libglademm/libglademm-2.6.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-cpp/libglademm/libglademm-2.6.0.ebuild b/dev-cpp/libglademm/libglademm-2.6.0.ebuild
new file mode 100644
index 000000000000..a86c72972623
--- /dev/null
+++ b/dev-cpp/libglademm/libglademm-2.6.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-cpp/libglademm/libglademm-2.6.0.ebuild,v 1.1 2005/07/18 21:48:07 ka0ttic Exp $
+
+inherit gnome2
+
+DESCRIPTION="C++ bindings for libglade"
+HOMEPAGE="http://gtkmm.sourceforge.net/"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/sources/libglademm/2.6/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="2.4"
+KEYWORDS="~amd64 ~ppc ~x86 ~sparc ~ppc64"
+IUSE=""
+
+RDEPEND=">=gnome-base/libglade-2.3.6
+ >=dev-cpp/gtkmm-2.6"
+DEPEND=">=dev-util/pkgconfig-0.12.0
+ ${RDEPEND}"
+
+src_compile() {
+ if useq amd64 || useq ppc64; then
+ aclocal -I scripts
+ libtoolize --force --copy
+ automake -c -f
+ autoconf
+ fi
+
+ gnome2_src_compile
+}
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"