summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet')
-rw-r--r--dev-dotnet/pe-format/ChangeLog8
-rw-r--r--dev-dotnet/pe-format/pe-format-2.1.ebuild33
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-dotnet/pe-format/ChangeLog b/dev-dotnet/pe-format/ChangeLog
index 67332ea8631d..5c2b8cead4b3 100644
--- a/dev-dotnet/pe-format/ChangeLog
+++ b/dev-dotnet/pe-format/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-dotnet/pe-format
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.31 2011/09/09 20:30:45 chainsaw Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/ChangeLog,v 1.32 2011/10/17 08:37:17 mgorny Exp $
+
+*pe-format-2.1 (17 Oct 2011)
+
+ 17 Oct 2011; Michał Górny <mgorny@gentoo.org> +pe-format-2.1.ebuild:
+ Version bump. The new version reuses binfmt.d directory, and thus is
+ compatible both with new OpenRC and systemd.
09 Sep 2011; Tony Vroon <chainsaw@gentoo.org> pe-format-2.0.5.ebuild:
Marked stable based on arch testing by Ian "idella4" Delaney & Agostino "ago"
diff --git a/dev-dotnet/pe-format/pe-format-2.1.ebuild b/dev-dotnet/pe-format/pe-format-2.1.ebuild
new file mode 100644
index 000000000000..fb1f0871b448
--- /dev/null
+++ b/dev-dotnet/pe-format/pe-format-2.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/pe-format/pe-format-2.1.ebuild,v 1.1 2011/10/17 08:37:17 mgorny Exp $
+
+EAPI=4
+inherit autotools-utils systemd
+
+DESCRIPTION="Intelligent PE executable wrapper for binfmt_misc"
+HOMEPAGE="https://github.com/mgorny/pe-format2/"
+SRC_URI="mirror://github/mgorny/${PN}2/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.9.4"
+
+src_configure() {
+ systemd_to_myeconfargs
+ autotools-utils_src_configure
+}
+
+src_install() {
+ autotools-utils_src_install
+ keepdir /var/lib
+}
+
+pkg_postinst() {
+ ebegin "Calling pe-format2-setup to update handler setup"
+ pe-format2-setup
+ eend ${?}
+}