summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/gigi/files/gigi-0.8_pre20120910-libtool.patch')
-rw-r--r--dev-games/gigi/files/gigi-0.8_pre20120910-libtool.patch93
1 files changed, 0 insertions, 93 deletions
diff --git a/dev-games/gigi/files/gigi-0.8_pre20120910-libtool.patch b/dev-games/gigi/files/gigi-0.8_pre20120910-libtool.patch
deleted file mode 100644
index 29a7a4071eeb..000000000000
--- a/dev-games/gigi/files/gigi-0.8_pre20120910-libtool.patch
+++ /dev/null
@@ -1,93 +0,0 @@
-diff -U 3 -dHrN gigi-0.8_pre20120910.orig/CMakeLists.txt gigi-0.8_pre20120910/CMakeLists.txt
---- gigi-0.8_pre20120910.orig/CMakeLists.txt 2012-09-10 18:48:32.272877323 -0700
-+++ gigi-0.8_pre20120910/CMakeLists.txt 2012-09-10 18:48:49.759553898 -0700
-@@ -228,36 +228,6 @@
- ########################################
- # Header Generation #
- ########################################
--if (NOT EXISTS ${CMAKE_HOME_DIRECTORY}/libltdl/config.h)
-- if (UNIX)
-- message("-- Configuring libltdl using \"libltdl/configure\" ...")
-- execute_process(
-- COMMAND ${CMAKE_HOME_DIRECTORY}/libltdl/configure
-- WORKING_DIRECTORY ${CMAKE_HOME_DIRECTORY}/libltdl
-- OUTPUT_QUIET
-- )
-- else ()
-- file(WRITE ${CMAKE_HOME_DIRECTORY}/libltdl/config.h
-- "/* WARNING: Generated by GG's build system. All local changes will be lost! */
--#define error_t int
--#define HAVE_STDIO_H 1
--#define HAVE_STDLIB_H 1
--#define HAVE_STRING_H 1
--#define HAVE_CTYPE_H 1
--#define HAVE_MEMORY_H 1
--#define HAVE_ERRNO_H 1
--#define __WIN32__
--#define HAVE_MEMCPY 1
--#define HAVE_MEMMOVE 1
--#define LTDL_OBJDIR \".libs\"
--#define LTDL_DLOPEN_DEPLIBS 1
--#define LTDL_SHLIBPATH_VAR \"PATH\"
--#define LTDL_SHLIB_EXT \".dll\"
--"
-- )
-- endif ()
--endif ()
--
- configure_file(
- ${CMAKE_HOME_DIRECTORY}/cmake/Config.h.in
- ${CMAKE_HOME_DIRECTORY}/GG/Config.h
-diff -U 3 -dHrN gigi-0.8_pre20120910.orig/GG/PluginInterface.h gigi-0.8_pre20120910/GG/PluginInterface.h
---- gigi-0.8_pre20120910.orig/GG/PluginInterface.h 2012-09-10 18:48:32.301876786 -0700
-+++ gigi-0.8_pre20120910/GG/PluginInterface.h 2012-09-10 18:49:02.264322634 -0700
-@@ -35,7 +35,7 @@
- #if defined(__APPLE__) && defined(__MACH__)
- # include "../libltdl/ltdl.h"
- #else
--# include <GG/ltdl.h>
-+# include <ltdl.h>
- #endif
-
- #include <string>
-diff -U 3 -dHrN gigi-0.8_pre20120910.orig/src/CMakeLists.txt gigi-0.8_pre20120910/src/CMakeLists.txt
---- gigi-0.8_pre20120910.orig/src/CMakeLists.txt 2012-09-10 18:48:32.327876305 -0700
-+++ gigi-0.8_pre20120910/src/CMakeLists.txt 2012-09-10 18:48:49.759553898 -0700
-@@ -50,8 +50,6 @@
- dialogs/FileDlg.cpp
- dialogs/ThreeButtonDlg.cpp
-
-- ../libltdl/ltdl.c
--
- adobe/adam.cpp
- adobe/adam_evaluate.cpp
- adobe/adam_parser.cpp
-@@ -162,14 +160,21 @@
- )
- endif ()
-
--set_source_files_properties(${CMAKE_HOME_DIRECTORY}/libltdl/ltdl.c PROPERTIES COMPILE_DEFINITIONS HAVE_CONFIG_H=1)
--execute_process(
-- COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_HOME_DIRECTORY}/libltdl/ltdl.h ${CMAKE_HOME_DIRECTORY}/GG/ltdl.h
-- COMMAND ${CMAKE_COMMAND} -E copy_if_different ${CMAKE_HOME_DIRECTORY}/libltdl/config.h ${CMAKE_HOME_DIRECTORY}/GG/ltdl_config.h
--)
--set_source_files_properties(${CMAKE_HOME_DIRECTORY}/GG/ltdl.h ${CMAKE_HOME_DIRECTORY}/GG/ltdl_config.h PROPERTIES GENERATED true)
-+find_library(LIBTOOL_LIB ltdl)
-+if (LIBTOOL_LIB)
-+ MESSAGE(STATUS " libtool-libraries : ${LIBTOOL_LIB}")
-+else (LIBTOOL_LIB)
-+ MESSAGE(FATAL_ERROR "libtool library not found!")
-+endif (LIBTOOL_LIB)
-
--set(THIS_LIB_LINK_LIBS ${Boost_LIBRARIES} ${OPENGL_LIBRARIES} ${FREETYPE_LIBRARIES})
-+find_file(LIBTOOL_HEADER ltdl.h PATHS ${CMAKE_INCLUDE_PATH})
-+if (LIBTOOL_HEADER)
-+ MESSAGE(STATUS " libtool-header : ${LIBTOOL_HEADER}")
-+else (LIBTOOL_HEADER)
-+ MESSAGE(FATAL_ERROR "libtool header not found!")
-+endif (LIBTOOL_HEADER)
-+
-+set(THIS_LIB_LINK_LIBS ${Boost_LIBRARIES} ${OPENGL_LIBRARIES} ${FREETYPE_LIBRARIES} ${LIBTOOL_LIB})
- if (USE_DEVIL)
- list(APPEND THIS_LIB_LINK_LIBS ${IL_LIBRARY} ${ILUT_LIBRARY})
- else ()