summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/jdepend/jdepend-2.8.ebuild')
-rw-r--r--dev-java/jdepend/jdepend-2.8.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-java/jdepend/jdepend-2.8.ebuild b/dev-java/jdepend/jdepend-2.8.ebuild
new file mode 100644
index 000000000000..9af19cbf7ca4
--- /dev/null
+++ b/dev-java/jdepend/jdepend-2.8.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-java/jdepend/jdepend-2.8.ebuild,v 1.1 2004/08/31 03:54:12 zx Exp $
+
+inherit java-pkg
+
+DESCRIPTION="JDepend traverses Java class file directories and generates design quality metrics for each Java package."
+HOMEPAGE="http://www.clarkware.com/software/JDepend.html"
+SRC_URI="http://www.clarkware.com/software/${PN}-${PV}.zip"
+LICENSE="jdepend"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="doc jikes"
+DEPEND=">=virtual/jdk-1.3
+ >=app-arch/unzip-5.50-r1
+ >=dev-java/ant-1.4
+ jikes? ( >=dev-java/jikes-1.17 )"
+RDEPEND=">=virtual/jdk-1.3"
+RESTRICT="nomirror"
+
+#TODO Do junit testing but resolve the circular dependency we have with ant.
+src_compile() {
+ local myc
+
+ if use jikes ; then
+ myc="${myc} -Dbuild.compiler=jikes"
+ fi
+
+# use junit && export CLASSPATH=$CLASSPATH:`java-config --classpath=junit`
+
+ ant ${myc} jar || die "Failed Compiling"
+
+# if use junit ; then
+# ant test || die "Failed Testing Packages Integrity"
+# fi
+}
+
+src_install() {
+ java-pkg_dojar lib/jdepend.jar || die "Failed Installing"
+ dodoc LICENSE README
+
+ dodir /usr/share/ant/lib
+ dosym /usr/share/jdepend/lib/jdepend.jar /usr/share/ant/lib
+
+ if use doc; then
+ dohtml docs/JDepend.html
+ cp -r docs/api ${D}/usr/share/doc/${PN}-${PV}/html
+ cp -r docs/images ${D}/usr/share/doc/${PN}-${PV}/html
+ fi
+}