summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/xalan/xalan-2.6.0.ebuild')
-rw-r--r--dev-java/xalan/xalan-2.6.0.ebuild15
1 files changed, 11 insertions, 4 deletions
diff --git a/dev-java/xalan/xalan-2.6.0.ebuild b/dev-java/xalan/xalan-2.6.0.ebuild
index 63f2a6e63c3a..5c67c566c6d2 100644
--- a/dev-java/xalan/xalan-2.6.0.ebuild
+++ b/dev-java/xalan/xalan-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/xalan-2.6.0.ebuild,v 1.1 2004/07/16 20:08:01 axxo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/xalan/xalan-2.6.0.ebuild,v 1.2 2004/07/27 16:17:47 axxo Exp $
inherit java-pkg eutils
@@ -20,15 +20,22 @@ DEPEND=">=virtual/jdk-1.3
RDEPEND=">=virtual/jdk-1.3
>=dev-java/xerces-2.6.0"
+can_build_doc() {
+ if [ `java-config --java-version 2>&1 | grep "1\.4\." | wc -l` -lt 1 ] ; then
+ return 0
+ else
+ return 1
+ fi
+}
+
src_compile() {
CLASSPATH=$CLASSPATH:`pwd`/bin/xercesImpl.jar:`pwd`/bin/bsf.jar:`pwd`/src\
ant jar ${myc} || die "build failed"
if use doc ; then
- if [ `java-config --java-version 2>&1 | grep "1\.4\." | wc -l` -lt 1 ] ; then
+ if can_build_doc ; then
ant javadocs || die "Build Javadocs Failed"
else
- USE=""
einfo " "
einfo " 1.4.x JDKs are unable to compile Javadocs at this time. "
einfo " "
@@ -48,7 +55,7 @@ src_install () {
}
pkg_postinst() {
- if use doc ; then
+ if use doc && can_build_doc ; then
einfo " "
einfo " API Documentation is in /usr/share/doc/${PN}-${PV}. "
einfo " "