summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java')
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild6
-rw-r--r--dev-java/commons-beanutils/commons-beanutils-1.5.ebuild51
-rw-r--r--dev-java/commons-beanutils/files/digest-commons-beanutils-1.51
-rw-r--r--dev-java/commons-collections/commons-collections-2.1-r1.ebuild4
-rw-r--r--dev-java/commons-digester/commons-digester-1.3-r1.ebuild6
-rw-r--r--dev-java/commons-digester/commons-digester-1.3.ebuild53
-rw-r--r--dev-java/commons-digester/files/digest-commons-digester-1.31
-rw-r--r--dev-java/commons-lang/commons-lang-1.0-r1.ebuild4
-rw-r--r--dev-java/commons-lang/commons-lang-1.0.1.ebuild4
-rw-r--r--dev-java/commons-lang/commons-lang-1.0.ebuild43
-rw-r--r--dev-java/commons-lang/files/digest-commons-lang-1.01
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild4
-rw-r--r--dev-java/commons-logging/commons-logging-1.0.2.ebuild44
-rw-r--r--dev-java/commons-logging/files/digest-commons-logging-1.0.21
-rw-r--r--dev-java/oro/files/digest-oro-2.0.61
-rw-r--r--dev-java/oro/oro-2.0.6-r1.ebuild4
-rw-r--r--dev-java/oro/oro-2.0.6.ebuild32
17 files changed, 16 insertions, 244 deletions
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild
index cfff10dc724b..079e6a2b0c52 100644
--- a/dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild
+++ b/dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild,v 1.2 2002/12/08 04:29:52 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/commons-beanutils-1.5-r1.ebuild,v 1.3 2002/12/15 16:19:49 strider Exp $
S=${WORKDIR}/${PN}-${PV}-src
DESCRIPTION="The Jakarta BeanUtils component provides easy-to-use wrappers around Reflection and Introspection APIs"
@@ -10,8 +10,8 @@ DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
>=dev-java/commons-collections-2.1
>=dev-java/commons-logging-1.0.2
- junit? ( >=junit-3.7 )"
-RDEPEND=">=virtual/jre-1.4
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jdk-1.3
>=dev-java/commons-collections-2.1
>=dev-java/commons-logging-1.0.2"
LICENSE="Apache-1.1"
diff --git a/dev-java/commons-beanutils/commons-beanutils-1.5.ebuild b/dev-java/commons-beanutils/commons-beanutils-1.5.ebuild
deleted file mode 100644
index 4f75301c9ea8..000000000000
--- a/dev-java/commons-beanutils/commons-beanutils-1.5.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-beanutils/commons-beanutils-1.5.ebuild,v 1.3 2002/11/08 01:16:16 blizzy Exp $
-
-S=${WORKDIR}/${PN}-${PV}-src
-DESCRIPTION="The Jakarta BeanUtils component provides easy-to-use wrappers around Reflection and Introspection APIs"
-HOMEPAGE="http://jakarta.apache.org/commons/beanutils.html"
-SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-1.4
- >=dev-java/commons-collections-2.1
- >=dev-java/commons-logging-1.0.2
- junit? ( >=junit-3.7 )"
-RDEPEND=">=virtual/jre-1.4
- >=dev-java/commons-collections-2.1
- >=dev-java/commons-logging-1.0.2"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="jikes junit"
-
-src_compile() {
- local myc
-
- cp beanutils/LICENSE.txt LICENSE
-
- cd beanutils
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
- echo "commons-logging.jar=`java-config --classpath=commons-logging`" | sed s/\=.*:/\=/ >> build.properties
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if [ -n "`use junit`" ] ; then
- echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// >> build.properties
- ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
- fi
-
- ANT_OPTS=${myc} ant jar || die "Compilation Failed"
- ANT_OPTS=${myc} ant javadoc || die "Unable to create documents"
-}
-
-src_install () {
- cd beanutils
- mv dist/${PN}*.jar dist/${PN}-${PV}.jar
- dojar dist/${PN}-${PV}.jar || die "Unable to install"
- dodoc RELEASE-NOTES.txt
- dohtml STATUS.html PROPOSAL.html
- dohtml -r dist/docs/*
-}
diff --git a/dev-java/commons-beanutils/files/digest-commons-beanutils-1.5 b/dev-java/commons-beanutils/files/digest-commons-beanutils-1.5
deleted file mode 100644
index 8243b7d47c16..000000000000
--- a/dev-java/commons-beanutils/files/digest-commons-beanutils-1.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 8841051dc2070b56140a3285f4085cbf commons-beanutils-1.5-src.tar.gz 127638
diff --git a/dev-java/commons-collections/commons-collections-2.1-r1.ebuild b/dev-java/commons-collections/commons-collections-2.1-r1.ebuild
index 66653ce6eb7e..cc30f3ea3066 100644
--- a/dev-java/commons-collections/commons-collections-2.1-r1.ebuild
+++ b/dev-java/commons-collections/commons-collections-2.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.1-r1.ebuild,v 1.4 2002/11/25 01:12:58 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-collections/commons-collections-2.1-r1.ebuild,v 1.5 2002/12/15 16:19:49 strider Exp $
S=${WORKDIR}/${PN}-${PV}-src
DESCRIPTION="Jakarta-Commons Collections Component"
@@ -8,7 +8,7 @@ HOMEPAGE="http://jakarta.apache.org/commons/collections.html"
SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
DEPEND=">=virtual/jdk-1.3
>=ant-1.4
- junit? ( >=junit-3.7 )"
+ junit? ( >=dev-java/junit-3.7 )"
RDEPEND=">=virtual/jre-1.3"
LICENSE="Apache-1.1"
SLOT="0"
diff --git a/dev-java/commons-digester/commons-digester-1.3-r1.ebuild b/dev-java/commons-digester/commons-digester-1.3-r1.ebuild
index 4b5dc150e0fd..d67b00abe9f0 100644
--- a/dev-java/commons-digester/commons-digester-1.3-r1.ebuild
+++ b/dev-java/commons-digester/commons-digester-1.3-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-digester/commons-digester-1.3-r1.ebuild,v 1.2 2002/12/08 04:29:52 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-digester/commons-digester-1.3-r1.ebuild,v 1.3 2002/12/15 16:19:49 strider Exp $
S=${WORKDIR}/${PN}-${PV}-src
DESCRIPTION="The Jakarta Digester component reads XML configuration files to provide initialization of various Java objects within the system."
@@ -10,8 +10,8 @@ DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
>=dev-java/commons-beanutils-1.5
>=dev-java/commons-collections-2.1
- junit? ( >=junit-3.7 )"
-RDEPEND=">=virtual/jre-1.4
+ junit? ( >=dev-java/junit-3.7 )"
+RDEPEND=">=virtual/jdk-1.3
>=dev-java/commons-beanutils-1.5
>=dev-java/commons-collections-2.1
>=dev-java/commons-logging-1.0.2"
diff --git a/dev-java/commons-digester/commons-digester-1.3.ebuild b/dev-java/commons-digester/commons-digester-1.3.ebuild
deleted file mode 100644
index 65b0268661b8..000000000000
--- a/dev-java/commons-digester/commons-digester-1.3.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-digester/commons-digester-1.3.ebuild,v 1.2 2002/11/08 01:16:16 blizzy Exp $
-
-S=${WORKDIR}/${PN}-${PV}-src
-DESCRIPTION="The Jakarta Digester component reads XML configuration files to provide initialization of various Java objects within the system."
-HOMEPAGE="http://jakarta.apache.org/commons/digester.html"
-SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.4
- >=dev-java/ant-1.4
- >=dev-java/commons-beanutils-1.5
- >=dev-java/commons-collections-2.1
- junit? ( >=junit-3.7 )"
-RDEPEND=">=virtual/jre-1.4
- >=dev-java/commons-beanutils-1.5
- >=dev-java/commons-collections-2.1
- >=dev-java/commons-logging-1.0.2"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="jikes junit"
-
-src_compile() {
- local myc
-
- cp digester/LICENSE.txt LICENSE
- cd digester
-
- echo "commons-collections.jar=`java-config --classpath=commons-collections`" > build.properties
- echo "commons-beanutils.jar=`java-config --classpath=commons-beanutils`" >> build.properties
- echo "commons-logging.jar=`java-config --classpath=commons-logging`" | sed s/\=.*:/\=/ >> build.properties
-
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if [ -n "`use junit`" ] ; then
- echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// >> build.properties
- ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
- fi
-
- ANT_OPTS=${myc} ant dist || die "Compilation Failed"
-}
-
-src_install () {
- cd digester
- mv dist/${PN}*.jar dist/${PN}-${PV}.jar
- dojar dist/${PN}-${PV}.jar || die "Unable to install"
- dodoc RELEASE-NOTES.txt
- dohtml STATUS.html PROPOSAL.html
- dohtml -r dist/docs/*
-}
diff --git a/dev-java/commons-digester/files/digest-commons-digester-1.3 b/dev-java/commons-digester/files/digest-commons-digester-1.3
deleted file mode 100644
index 812e9dc1d62d..000000000000
--- a/dev-java/commons-digester/files/digest-commons-digester-1.3
+++ /dev/null
@@ -1 +0,0 @@
-MD5 0dafb55a57c4bd3b2a941d2961b139c8 commons-digester-1.3-src.tar.gz 102400
diff --git a/dev-java/commons-lang/commons-lang-1.0-r1.ebuild b/dev-java/commons-lang/commons-lang-1.0-r1.ebuild
index c9fa07224975..48d276aa930d 100644
--- a/dev-java/commons-lang/commons-lang-1.0-r1.ebuild
+++ b/dev-java/commons-lang/commons-lang-1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0-r1.ebuild,v 1.1 2002/11/25 01:14:49 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0-r1.ebuild,v 1.2 2002/12/15 16:19:49 strider Exp $
S="${WORKDIR}/${PN}-${PV}-src"
DESCRIPTION="Jakarta components to manipulate core java classes"
@@ -8,7 +8,7 @@ HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
- junit? ( >=junit-3.7 )"
+ junit? ( >=dev-java/junit-3.7 )"
RDEPEND=">=virtual/jre-1.3"
LICENSE="Apache-1.1"
SLOT="0"
diff --git a/dev-java/commons-lang/commons-lang-1.0.1.ebuild b/dev-java/commons-lang/commons-lang-1.0.1.ebuild
index a935c6a03b36..fa23bbed7c39 100644
--- a/dev-java/commons-lang/commons-lang-1.0.1.ebuild
+++ b/dev-java/commons-lang/commons-lang-1.0.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0.1.ebuild,v 1.1 2002/12/02 23:10:39 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0.1.ebuild,v 1.2 2002/12/15 16:19:49 strider Exp $
S="${WORKDIR}/${PN}-${PV}-src"
DESCRIPTION="Jakarta components to manipulate core java classes"
@@ -8,7 +8,7 @@ HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
DEPEND=">=virtual/jdk-1.3
>=dev-java/ant-1.4
- junit? ( >=junit-3.7 )"
+ junit? ( >=dev-java/junit-3.7 )"
RDEPEND=">=virtual/jre-1.3"
LICENSE="Apache-1.1"
SLOT="0"
diff --git a/dev-java/commons-lang/commons-lang-1.0.ebuild b/dev-java/commons-lang/commons-lang-1.0.ebuild
deleted file mode 100644
index e8b89189872d..000000000000
--- a/dev-java/commons-lang/commons-lang-1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-lang/commons-lang-1.0.ebuild,v 1.4 2002/12/15 10:44:11 bjb Exp $
-
-S="${WORKDIR}/${PN}-${PV}-src"
-DESCRIPTION="Jakarta components to manipulate core java classes"
-HOMEPAGE="http://jakarta.apache.org/commons/lang.html"
-SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${PN}-${PV}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4
- junit? ( >=junit-3.7 )"
-RDEPEND=">=virtual/jre-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
-IUSE="jikes junit"
-
-src_compile() {
- local myc
-
- cp lang/LICENSE.txt LICENSE
- cd lang
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if [ -n "`use junit`" ] ; then
- echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// > build.properties
- ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
- fi
-
- ANT_OPTS=${myc} ant jar || die "Compilation Failed"
- ANT_OPTS=${myc} ant javadoc || die "Building Documents Failed"
-}
-
-src_install () {
- cd lang
- dodoc RELEASE-NOTES.txt
- dojar dist/${PN}*.jar || die "Unable to install"
- dohtml -r dist/docs/*
- dohtml PROPOSAL.html STATUS.html
-}
diff --git a/dev-java/commons-lang/files/digest-commons-lang-1.0 b/dev-java/commons-lang/files/digest-commons-lang-1.0
deleted file mode 100644
index f990d8d79f82..000000000000
--- a/dev-java/commons-lang/files/digest-commons-lang-1.0
+++ /dev/null
@@ -1 +0,0 @@
-MD5 d367df1f903c5b6d6a5f24d51db0df5d commons-lang-1.0-src.tar.gz 90747
diff --git a/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild b/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild
index 38a10a63c367..b4d4e3009b67 100644
--- a/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild
+++ b/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild,v 1.5 2002/12/08 04:29:52 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.2-r1.ebuild,v 1.6 2002/12/15 16:19:49 strider Exp $
S="${WORKDIR}/${P}-src"
DESCRIPTION="The Jakarta-Commons Logging package is an ultra-thin bridge between different logging libraries."
@@ -9,7 +9,7 @@ SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/$
DEPEND=">=virtual/jdk-1.3
>=dev-java/log4j-1.2.5
>=dev-java/ant-1.4"
-RDEPEND=">=virtual/jre-1.4"
+RDEPEND=">=virtual/jdk-1.3"
LICENSE="Apache-1.1"
SLOT="0"
KEYWORDS="x86"
diff --git a/dev-java/commons-logging/commons-logging-1.0.2.ebuild b/dev-java/commons-logging/commons-logging-1.0.2.ebuild
deleted file mode 100644
index 944b1b18aa1a..000000000000
--- a/dev-java/commons-logging/commons-logging-1.0.2.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/commons-logging/commons-logging-1.0.2.ebuild,v 1.2 2002/11/08 01:16:16 blizzy Exp $
-
-S="${WORKDIR}/${P}-src"
-DESCRIPTION="Jakarta component that abstract logging API"
-HOMEPAGE="http://jakarta.apache.org/commons/logging.html"
-SRC_URI="http://jakarta.apache.org/builds/jakarta-commons/release/${PN}/v${PV}/${P}-src.tar.gz"
-DEPEND=">=virtual/jdk-1.3
- >=dev-java/ant-1.4"
-RDEPEND=">=virtual/jre-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="jikes junit"
-
-src_compile() {
- local myc
-
- cd logging
- cp LICENSE.txt ../LICENSE
-
- if [ -n "`use jikes`" ] ; then
- myc="${myc} -Dbuild.compiler=jikes"
- fi
-
- if [ -n "`use junit`" ] ; then
- echo "junit.jar=`java-config --classpath=junit`" | sed s/:.*// > build.properties
- ANT_OPTS=${myc} ant test || die "Testing Classes Failed"
- fi
-
- echo "log4j.jar=`java-config --classpath=log4j`" >> build.properties
-
- ANT_OPTS=${myc} ant dist || die "Compilation failed"
-}
-
-src_install () {
- cd logging
- dojar dist/commons-logging-api.jar || die "Unable to install"
- dojar dist/commons-logging.jar || die "Unable to install"
- dodoc RELEASE-NOTES.txt
- dohtml PROPOSAL.html STATUS.html usersguide.html
- dohtml -r dist/docs/*
-}
diff --git a/dev-java/commons-logging/files/digest-commons-logging-1.0.2 b/dev-java/commons-logging/files/digest-commons-logging-1.0.2
deleted file mode 100644
index 608ab555e60d..000000000000
--- a/dev-java/commons-logging/files/digest-commons-logging-1.0.2
+++ /dev/null
@@ -1 +0,0 @@
-MD5 78bfaac25906a54b925bcc285872c9c9 commons-logging-1.0.2-src.tar.gz 33550
diff --git a/dev-java/oro/files/digest-oro-2.0.6 b/dev-java/oro/files/digest-oro-2.0.6
deleted file mode 100644
index 534a18cbe24f..000000000000
--- a/dev-java/oro/files/digest-oro-2.0.6
+++ /dev/null
@@ -1 +0,0 @@
-MD5 a1698f1a325584a6fc32690cd58d9986 jakarta-oro-2.0.6.tar.gz 331423
diff --git a/dev-java/oro/oro-2.0.6-r1.ebuild b/dev-java/oro/oro-2.0.6-r1.ebuild
index fb89d20b24c9..22e935c1920f 100644
--- a/dev-java/oro/oro-2.0.6-r1.ebuild
+++ b/dev-java/oro/oro-2.0.6-r1.ebuild
@@ -1,13 +1,13 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6-r1.ebuild,v 1.1 2002/11/25 01:39:18 strider Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6-r1.ebuild,v 1.2 2002/12/15 16:19:49 strider Exp $
S=${WORKDIR}/jakarta-oro-${PV}
DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
SRC_URI="http://jakarta.apache.org/builds/jakarta-oro/release/v${PV}/jakarta-oro-${PV}.tar.gz"
HOMEPAGE="http://jakarta.apache.org/oro/index.html"
DEPEND=">=virtual/jdk-1.3
- >=ant-1.4"
+ >=dev-java/ant-1.4"
REDEPND=">=virtual/jdk-1.3"
LICENSE="Apache-1.1"
SLOT="0"
diff --git a/dev-java/oro/oro-2.0.6.ebuild b/dev-java/oro/oro-2.0.6.ebuild
deleted file mode 100644
index 49f14d89e841..000000000000
--- a/dev-java/oro/oro-2.0.6.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/dev-java/oro/oro-2.0.6.ebuild,v 1.3 2002/12/15 10:44:11 bjb Exp $
-
-S=${WORKDIR}/jakarta-oro-${PV}
-DESCRIPTION="A set of text-processing Java classes that provide Perl5 compatible regular expressions, AWK-like regular expressions, glob expressions, and utility classes for performing substitutions, splits, filtering filenames, etc."
-SRC_URI="http://jakarta.apache.org/builds/jakarta-oro/release/v${PV}/jakarta-oro-${PV}.tar.gz"
-HOMEPAGE="http://jakarta.apache.org/oro/index.html"
-DEPEND=">=virtual/jdk-1.3
- >=ant-1.4"
-REDEPND=">=virtual/jdk-1.3"
-LICENSE="Apache-1.1"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~sparc ~alpha"
-IUSE=""
-
-src_compile() {
- ant jar || die
- ant javadocs || die
-}
-
-src_install () {
- dojar jakarta-oro*.jar
- dodoc BUGS CHANGES COMPILE CONTRIBUTORS README STYLE TODO
- dohtml *.html
- dodir /usr/share/doc/${P}
- dohtml -r docs/
-}
-
-pkg_postinst() {
- einfo "Documentation can be found at http://jakarta.apache.org/oro/index.html"
-}