summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.6.2-r2.ebuild')
-rw-r--r--dev-lang/python/python-2.6.2-r2.ebuild10
1 files changed, 5 insertions, 5 deletions
diff --git a/dev-lang/python/python-2.6.2-r2.ebuild b/dev-lang/python/python-2.6.2-r2.ebuild
index 6e58d4692ec8..d76deb11bf7b 100644
--- a/dev-lang/python/python-2.6.2-r2.ebuild
+++ b/dev-lang/python/python-2.6.2-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.3 2009/09/23 15:29:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.2-r2.ebuild,v 1.4 2009/09/24 14:31:26 arfrever Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -56,11 +56,11 @@ RDEPEND=">=app-admin/eselect-python-20080925
tk? ( >=dev-lang/tk-8.0 )
xml? ( >=dev-libs/expat-2 )
)
- !m68k? ( !mips? ( !sparc-fbsd? ( !x86-fbsd? ( virtual/libffi ) ) ) )"
+ !m68k? ( !mips? ( !sparc-fbsd? ( virtual/libffi ) ) )"
DEPEND="${RDEPEND}
- !m68k? ( !mips? ( !sparc-fbsd? ( !x86-fbsd? ( dev-util/pkgconfig ) ) ) )"
+ !m68k? ( !mips? ( !sparc-fbsd? ( dev-util/pkgconfig ) ) )"
PDEPEND="${RDEPEND} app-admin/python-updater"
-RDEPEND+=" app-misc/mime-types"
+RDEPEND+=" !build? ( app-misc/mime-types )"
PROVIDE="virtual/python"
@@ -185,7 +185,7 @@ src_configure() {
# Please query BSD team before removing this!
append-ldflags "-L."
- if ! use m68k && ! use mips && ! use sparc-fbsd && ! use x86-fbsd; then
+ if ! use m68k && ! use mips && ! use sparc-fbsd; then
myconf+=" --with-system-ffi"
fi