summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/tk/tk-8.3.4.ebuild')
-rw-r--r--dev-lang/tk/tk-8.3.4.ebuild14
1 files changed, 7 insertions, 7 deletions
diff --git a/dev-lang/tk/tk-8.3.4.ebuild b/dev-lang/tk/tk-8.3.4.ebuild
index 0441847d945e..c77b2e30f1ea 100644
--- a/dev-lang/tk/tk-8.3.4.ebuild
+++ b/dev-lang/tk/tk-8.3.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4.ebuild,v 1.5 2003/08/05 16:26:40 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/tk/tk-8.3.4.ebuild,v 1.6 2003/09/06 22:27:51 msterret Exp $
inherit eutils
@@ -41,10 +41,10 @@ src_install() {
#short version number
local v1
v1=${PV%.*}
-
+
cd ${S}/unix
make INSTALL_ROOT=${D} MAN_INSTALL_DIR=${D}/usr/share/man install || die
-
+
# fix the tkConfig.sh to eliminate refs to the build directory
sed -e "s,^TK_BUILD_LIB_SPEC='-L${S2}/unix,TCL_BUILD_LIB_SPEC='-L/usr/lib," \
-e "s,^TK_SRC_DIR='${S2}',TCL_SRC_DIR='/usr/lib/tk${v1}/include'," \
@@ -52,7 +52,7 @@ src_install() {
-e "s,^TK_BUILD_STUB_LIB_PATH='${S2}/unix,TCL_BUILD_STUB_LIB_PATH='/usr/lib," \
${D}/usr/lib/tkConfig.sh > ${D}/usr/lib/tkConfig.sh.new
mv ${D}/usr/lib/tkConfig.sh.new ${D}/usr/lib/tkConfig.sh
-
+
# install private headers
dodir /usr/lib/tk${v1}/include/unix
install -c -m0644 ${S}/unix/*.h ${D}/usr/lib/tk${v1}/include/unix
@@ -60,15 +60,15 @@ src_install() {
install -c -m0644 ${S}/generic/*.h ${D}/usr/lib/tk${v1}/include/generic
rm -f ${D}/usr/lib/tk${v1}/include/generic/tk.h
rm -f ${D}/usr/lib/tk${v1}/include/generic/tkDecls.h
- rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
+ rm -f ${D}/usr/lib/tk${v1}/include/generic/tkPlatDecls.h
# install symlink for libraries
#dosym /usr/lib/libtk${v1}.a /usr/lib/libtk.a
dosym /usr/lib/libtk${v1}.so /usr/lib/libtk.so
dosym /usr/lib/libtkstub${v1}.a /usr/lib/libtkstub.a
-
+
ln -sf wish${v1} ${D}/usr/bin/wish
-
+
cd ${S}
dodoc README changes license.terms
}