summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/python/ChangeLog7
-rw-r--r--dev-lang/python/python-2.3.5.ebuild16
-rw-r--r--dev-lang/python/python-2.4-r3.ebuild15
3 files changed, 25 insertions, 13 deletions
diff --git a/dev-lang/python/ChangeLog b/dev-lang/python/ChangeLog
index bc2e4a2f0bbf..569c4cc04a20 100644
--- a/dev-lang/python/ChangeLog
+++ b/dev-lang/python/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-lang/python
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.136 2005/04/20 17:10:29 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/ChangeLog,v 1.137 2005/04/20 18:48:48 liquidx Exp $
+
+ 20 Apr 2005; Alastair Tse <liquidx@gentoo.org> python-2.3.5.ebuild,
+ python-2.4-r3.ebuild:
+ reverting changes to deps and adding note about why they are arranged in
+ that way (to remind myself never to touch them again :)
20 Apr 2005; Alastair Tse <liquidx@gentoo.org>
+files/python-2.3-readline.patch, +files/python-2.4-readline.patch,
diff --git a/dev-lang/python/python-2.3.5.ebuild b/dev-lang/python/python-2.3.5.ebuild
index f44987945686..6329fbf45be9 100644
--- a/dev-lang/python/python-2.3.5.ebuild
+++ b/dev-lang/python/python-2.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.4 2005/04/20 17:10:29 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.3.5.ebuild,v 1.5 2005/04/20 18:48:48 liquidx Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -23,8 +23,7 @@ SLOT="2.3"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86"
IUSE="ncurses gdbm ssl readline tcltk berkdb bootstrap ipv6 build ucs2 doc X"
-RDEPEND="virtual/libc
- dev-python/python-fchksum
+DEPEND="virtual/libc
>=sys-libs/zlib-1.1.3
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
@@ -36,10 +35,15 @@ RDEPEND="virtual/libc
dev-libs/expat
)"
-DEPEND="${RDEPEND}"
+# NOTE: The dev-python/python-fchksum RDEPEND is needed so that this python
+# provides the functionality expected from previous pythons.
+
+# NOTE: python-fchksum is only a RDEPEND and not a DEPEND since we don't need
+# it to compile python. We just need to ensure that when we install
+# python, we definitely have fchksum support. - liquidx
+
+RDEPEND="${DEPEND} dev-python/python-fchksum"
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
PROVIDE="virtual/python"
diff --git a/dev-lang/python/python-2.4-r3.ebuild b/dev-lang/python/python-2.4-r3.ebuild
index f7d66778900d..1515f97039c8 100644
--- a/dev-lang/python/python-2.4-r3.ebuild
+++ b/dev-lang/python/python-2.4-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.2 2005/04/20 17:10:29 liquidx Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.4-r3.ebuild,v 1.3 2005/04/20 18:48:48 liquidx Exp $
# NOTE about python-portage interactions :
# - Do not add a pkg_setup() check for a certain version of portage
@@ -24,9 +24,8 @@ SLOT="2.4"
KEYWORDS="~x86 ~ppc ~sparc ~arm ~hppa ~amd64 ~s390 ~alpha ~ia64 ~mips"
-RDEPEND="virtual/libc
+DEPEND="virtual/libc
>=sys-libs/zlib-1.1.3
- dev-python/python-fchksum
!build? (
X? ( tcltk? ( >=dev-lang/tk-8.0 ) )
ncurses? ( >=sys-libs/ncurses-5.2 readline? ( >=sys-libs/readline-4.1 ) )
@@ -37,10 +36,14 @@ RDEPEND="virtual/libc
dev-libs/expat
)"
-DEPEND="${RDEPEND}"
+# NOTE: The dev-python/python-fchksum RDEPEND is needed so that this python
+# provides the functionality expected from previous pythons.
-# The dev-python/python-fchksum RDEPEND is needed to that this python provides
-# the functionality expected from previous pythons.
+# NOTE: python-fchksum is only a RDEPEND and not a DEPEND since we don't need
+# it to compile python. We just need to ensure that when we install
+# python, we definitely have fchksum support. - liquidx
+
+RDEPEND="${DEPEND} dev-python/python-fchksum"
PROVIDE="virtual/python"