summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/ocaml/ChangeLog6
-rw-r--r--dev-lang/ocaml/ocaml-3.04-r1.ebuild5
-rw-r--r--dev-lang/ocaml/ocaml-3.06.ebuild6
3 files changed, 14 insertions, 3 deletions
diff --git a/dev-lang/ocaml/ChangeLog b/dev-lang/ocaml/ChangeLog
index 446df04f4e8a..dd8715bf94e4 100644
--- a/dev-lang/ocaml/ChangeLog
+++ b/dev-lang/ocaml/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for dev-lang/ocaml
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.9 2003/02/12 05:57:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ChangeLog,v 1.10 2003/04/11 18:32:16 method Exp $
*ocaml-3.06 (28 Jan 2003)
+ 11 Apr 2003; Joshua Brindle <method@gentoo.org> ocaml-3.04-r1.ebuild,
+ ocaml-3.06.ebuild:
+ added filter-flags -fstack-protector
+
28 Jan 2003; Jon Nall <nall@gentoo.org> ocaml-3.06 :
who made this build? i didn't. i just added ~ppc to it.
diff --git a/dev-lang/ocaml/ocaml-3.04-r1.ebuild b/dev-lang/ocaml/ocaml-3.04-r1.ebuild
index 33913ac59f69..c99b66f6e731 100644
--- a/dev-lang/ocaml/ocaml-3.04-r1.ebuild
+++ b/dev-lang/ocaml/ocaml-3.04-r1.ebuild
@@ -1,9 +1,12 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.04-r1.ebuild,v 1.10 2003/02/13 10:27:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.04-r1.ebuild,v 1.11 2003/04/11 18:32:16 method Exp $
IUSE="tcltk"
+inherit flag-o-matic
+filter-flags "-fstack-protector"
+
S=${WORKDIR}/${P}
DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
SRC_URI="ftp://ftp.inria.fr/lang/caml-light/${P}.tar.gz"
diff --git a/dev-lang/ocaml/ocaml-3.06.ebuild b/dev-lang/ocaml/ocaml-3.06.ebuild
index cd808fb31830..fad5976c98eb 100644
--- a/dev-lang/ocaml/ocaml-3.06.ebuild
+++ b/dev-lang/ocaml/ocaml-3.06.ebuild
@@ -1,9 +1,13 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.7 2003/02/13 10:27:51 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/ocaml/ocaml-3.06.ebuild,v 1.8 2003/04/11 18:32:16 method Exp $
IUSE="tcltk"
+inherit flag-o-matic
+filter-flags "-fstack-protector"
+
+
S=${WORKDIR}/${P}
DESCRIPTION="Objective Caml is a fast modern type-inferring functional programming language descended from the ML (Meta Language) family."
SRC_URI="http://caml.inria.fr/distrib/${P}/${P}.tar.gz"