summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild')
-rw-r--r--dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild b/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild
index 766e7b33eb21..cb66b88083fc 100644
--- a/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild
+++ b/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild,v 1.6 2006/10/23 20:26:54 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/beecrypt/beecrypt-4.1.2-r1.ebuild,v 1.7 2006/11/13 19:04:04 sanchan Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
-inherit flag-o-matic eutils multilib autotools
+inherit flag-o-matic eutils multilib autotools java-pkg-opt-2
DESCRIPTION="general-purpose cryptography library"
HOMEPAGE="http://sourceforge.net/projects/beecrypt"
@@ -15,14 +15,21 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="java nocxx python threads"
-DEPEND="python? ( >=dev-lang/python-2.2 )
+COMMONDEPEND="python? ( >=dev-lang/python-2.2 )
!<app-arch/rpm-4.2.1"
+DEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jdk-1.4 )"
+
+RDEPEND="${COMMONDEPEND}
+ java? ( >=virtual/jre-1.4 )"
+
pkg_setup() {
ewarn "The MMX assembler code presents TEXTREL issues. If you don't want them try using"
ewarn "relaxed CFLAGS like -march=i686 instead of -march=pentium3 and so on."
ewarn "This ebuild fails on multilib system with multilib-strict on AMD64."
ewarn "Feel free to help upstream solving the above bugs."
+ java-pkg-opt-2_pkg_setup
}
src_unpack() {