summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/g-wrap/g-wrap-1.3.4.ebuild')
-rw-r--r--dev-libs/g-wrap/g-wrap-1.3.4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-libs/g-wrap/g-wrap-1.3.4.ebuild b/dev-libs/g-wrap/g-wrap-1.3.4.ebuild
new file mode 100644
index 000000000000..212f135be97c
--- /dev/null
+++ b/dev-libs/g-wrap/g-wrap-1.3.4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/g-wrap/g-wrap-1.3.4.ebuild,v 1.1 2003/03/17 06:38:25 edolnx Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A tool for exporting C libraries into Scheme"
+SRC_URI="http://www.gnucash.org/pub/g-wrap/source/${P}.tar.gz"
+HOMEPAGE="http://www.gnucash.org"
+
+SLOT="1.3"
+LICENSE="GPL-2"
+KEYWORDS="~x86 "
+
+inherit flag-o-matic
+
+filter-flags "-O?"
+
+DEPEND=">=dev-util/guile-1.4
+ >=dev-libs/slib-2.4.2"
+
+
+src_compile() {
+
+ econf \
+ --libexecdir=/usr/lib/misc || die
+
+# #GCC3 Compile fix, I tried to do this at the Makefile.in level
+# #but it hates me with a passion so it goes here.
+# for FILE in `find . -iname "Makefile"`
+# do
+# mv ${FILE} ${FILE}.old
+# sed -e "s: -I/usr/include : :" ${FILE}.old > ${FILE}
+# done
+
+ emake || die
+}
+
+src_install () {
+
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING ChangeLog NEWS README THANKS
+}