summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/libffi/files')
-rw-r--r--dev-libs/libffi/files/digest-libffi-3.3.3-r11
-rw-r--r--dev-libs/libffi/files/digest-libffi-3.4.1-r11
-rw-r--r--dev-libs/libffi/files/libffi-soversion.dpatch61
-rw-r--r--dev-libs/libffi/files/libffi-without-libgcj.dpatch67
4 files changed, 130 insertions, 0 deletions
diff --git a/dev-libs/libffi/files/digest-libffi-3.3.3-r1 b/dev-libs/libffi/files/digest-libffi-3.3.3-r1
new file mode 100644
index 000000000000..e87695155cb0
--- /dev/null
+++ b/dev-libs/libffi/files/digest-libffi-3.3.3-r1
@@ -0,0 +1 @@
+MD5 3c6cfd9fcd180481063b4058cf6faff2 gcc-3.3.3.tar.bz2 23279245
diff --git a/dev-libs/libffi/files/digest-libffi-3.4.1-r1 b/dev-libs/libffi/files/digest-libffi-3.4.1-r1
new file mode 100644
index 000000000000..ba271506dd42
--- /dev/null
+++ b/dev-libs/libffi/files/digest-libffi-3.4.1-r1
@@ -0,0 +1 @@
+MD5 31b459062499f9f68d451db9cbf3205c gcc-3.4.1.tar.bz2 27182385
diff --git a/dev-libs/libffi/files/libffi-soversion.dpatch b/dev-libs/libffi/files/libffi-soversion.dpatch
new file mode 100644
index 000000000000..45b95b9add40
--- /dev/null
+++ b/dev-libs/libffi/files/libffi-soversion.dpatch
@@ -0,0 +1,61 @@
+#! /bin/sh -e
+
+# DP: Install libffi with soversion 3.
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ #cd ${dir}gcc && autoconf
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ #rm ${dir}gcc/configure
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+diff -urN libffi.old/Makefile.am libffi/Makefile.am
+--- libffi.old/Makefile.am 2003-10-22 01:02:59.000000000 +0200
++++ libffi/Makefile.am 2004-02-21 10:06:49.000000000 +0100
+@@ -175,7 +175,7 @@
+
+ AM_CFLAGS = -Wall -g -fexceptions
+
+-libffi_la_LDFLAGS = -release $(VERSION)
++libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version`
+
+ INCLUDES = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
+
+diff -urN libffi.old/Makefile.in libffi/Makefile.in
+--- libffi.old/Makefile.in 2003-11-24 00:52:28.000000000 +0100
++++ libffi/Makefile.in 2004-02-21 10:06:49.000000000 +0100
+@@ -226,7 +226,7 @@
+
+ AM_CFLAGS = -Wall -g -fexceptions
+
+-libffi_la_LDFLAGS = -release $(VERSION)
++libffi_la_LDFLAGS = -version-info `grep -v '^\#' $(srcdir)/libtool-version`
+
+ INCLUDES = -I. -I$(top_srcdir)/include -Iinclude -I$(top_srcdir)/src
+ ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
+diff -urN libffi.old/libtool-version libffi/libtool-version
+--- libffi.old/libtool-version 1970-01-01 01:00:00.000000000 +0100
++++ libffi/libtool-version 2004-02-21 10:06:49.000000000 +0100
+@@ -0,0 +1,6 @@
++# This file is used to maintain libtool version info for libffi. See
++# the libtool manual to understand the meaning of the fields. This is
++# a separate file so that version updates don't involve re-running
++# automake.
++# CURRENT:REVISION:AGE
++3:0:0
diff --git a/dev-libs/libffi/files/libffi-without-libgcj.dpatch b/dev-libs/libffi/files/libffi-without-libgcj.dpatch
new file mode 100644
index 000000000000..f4732cad4015
--- /dev/null
+++ b/dev-libs/libffi/files/libffi-without-libgcj.dpatch
@@ -0,0 +1,67 @@
+#! /bin/sh -e
+
+# DP: build libffi without building libgcj
+
+dir=
+if [ $# -eq 3 -a "$2" = '-d' ]; then
+ pdir="-d $3"
+ dir="$3/"
+elif [ $# -ne 1 ]; then
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+fi
+case "$1" in
+ -patch)
+ patch $pdir -f --no-backup-if-mismatch -p0 < $0
+ #cd ${dir}gcc && autoconf
+ ;;
+ -unpatch)
+ patch $pdir -f --no-backup-if-mismatch -R -p0 < $0
+ #rm ${dir}gcc/configure
+ ;;
+ *)
+ echo >&2 "`basename $0`: script expects -patch|-unpatch as argument"
+ exit 1
+esac
+exit 0
+
+--- configure.in.orig 2004-08-03 00:53:36.000000000 +0200
++++ configure.in 2004-08-03 00:52:35.000000000 +0200
+@@ -136,8 +136,7 @@
+ host_tools="texinfo byacc flex bison binutils gas ld gcc sid sim gdb make patch prms send-pr gprof etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool diff rcs fileutils shellutils time textutils wdiff find uudecode hello tar gzip indent recode release sed utils guile perl gawk findutils gettext zip fastjar"
+
+ # libgcj represents the runtime libraries only used by gcj.
+-libgcj="target-libffi \
+- target-boehm-gc \
++libgcj="target-boehm-gc \
+ target-zlib \
+ target-qthreads \
+ target-libjava"
+@@ -150,6 +150,7 @@
+ target-libstdc++-v3 \
+ target-libf2c \
+ ${libgcj} \
++ target-libffi \
+ target-libobjc"
+
+ # these tools are built using the target libraries, and are intended to
+--- configure~ 2004-08-28 02:31:04.000000000 +0200
++++ configure 2004-08-28 10:55:28.000000000 +0200
+@@ -876,8 +876,7 @@
+ host_tools="texinfo byacc flex bison binutils gas ld gcc sid sim gdb make patch prms send-pr gprof etc expect dejagnu ash bash bzip2 m4 autoconf automake libtool diff rcs fileutils shellutils time textutils wdiff find uudecode hello tar gzip indent recode release sed utils guile perl gawk findutils gettext zip fastjar"
+
+ # libgcj represents the runtime libraries only used by gcj.
+-libgcj="target-libffi \
+- target-boehm-gc \
++libgcj="target-boehm-gc \
+ target-zlib \
+ target-qthreads \
+ target-libjava"
+@@ -891,6 +890,7 @@
+ target-libstdc++-v3 \
+ target-libf2c \
+ ${libgcj} \
++ target-libffi \
+ target-libobjc"
+
+ # these tools are built using the target libraries, and are intended to