summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/quantlib/quantlib-0.3.0.ebuild')
-rw-r--r--dev-libs/quantlib/quantlib-0.3.0.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/dev-libs/quantlib/quantlib-0.3.0.ebuild b/dev-libs/quantlib/quantlib-0.3.0.ebuild
index 384557c9bddb..c3f0481c0433 100644
--- a/dev-libs/quantlib/quantlib-0.3.0.ebuild
+++ b/dev-libs/quantlib/quantlib-0.3.0.ebuild
@@ -1,28 +1,23 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-0.3.0.ebuild,v 1.4 2003/02/13 10:51:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/quantlib/quantlib-0.3.0.ebuild,v 1.5 2003/03/25 20:13:29 seemant Exp $
-IUSE="libtool"
+IUSE=""
-Name="QuantLib"
-S=${WORKDIR}/${Name}-${PV}
+MY_P=${P/q/Q}
+MY_P=${MY_P/l/L}
+S=${WORKDIR}/${MY_P}
DESCRIPTION="A comprehensive software framework for quantitative finance"
-SRC_URI="mirror://sourceforge/quantlib/${Name}-${PV}-src.tar.gz"
-HOMEPAGE="www.quantlib.org"
+HOMEPAGE="http://www.quantlib.org"
+SRC_URI="mirror://sourceforge/quantlib/${MY_P}-src.tar.gz"
-DEPEND="libtool? ( sys-devel/libtool )"
+DEPEND="sys-devel/libtool"
SLOT="0"
LICENSE="BSD"
-KEYWORDS="x86 ~ppc ~sparc "
+KEYWORDS="x86 ~ppc ~sparc ~alpha ~mips ~hppa ~arm"
-src_compile(){
- econf || die "./configure failed"
- emake || die
-}
-
src_install(){
einstall || die "einstall failed"
- dodoc Authors.txt ChangeLog.txt Contributors.txt History.txt \
- INSTALL.txt LICENSE.txt News.txt Readme.txt TODO.txt
+ dodoc *.txt
}