summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp/gauche/gauche-0.5.7.ebuild')
-rw-r--r--dev-lisp/gauche/gauche-0.5.7.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-lisp/gauche/gauche-0.5.7.ebuild b/dev-lisp/gauche/gauche-0.5.7.ebuild
new file mode 100644
index 000000000000..e91c23ff9f62
--- /dev/null
+++ b/dev-lisp/gauche/gauche-0.5.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/gauche/gauche-0.5.7.ebuild,v 1.1 2002/07/11 23:58:09 karltk Exp $
+
+S=${WORKDIR}/Gauche-${PV}
+DESCRIPTION="A Unix system friendly scheme interpreter"
+SRC_URI="mirror://sourceforge/gauche/Gauche-${PV}.tgz"
+HOMEPAGE="http://gauche.sf.net"
+DEPEND="virtual/glibc"
+RDEPEND="$DEPEND"
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="x86"
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man || die "./configure failed"
+ emake || die
+ #make || die
+}
+
+src_install () {
+# make DESTDIR=${D} install || die
+ make \
+ prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+ dodoc COPYING INSTALL ChangeLog VERSION
+ doman doc/gosh.1 doc/gauche-config.1
+ dodoc doc/README
+}