summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lisp')
-rw-r--r--dev-lisp/sbcl/ChangeLog12
-rw-r--r--dev-lisp/sbcl/files/sbcl-1.0.55-newglibc.patch43
-rw-r--r--dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild12
3 files changed, 64 insertions, 3 deletions
diff --git a/dev-lisp/sbcl/ChangeLog b/dev-lisp/sbcl/ChangeLog
index 27b606b5dd4e..717703b8b936 100644
--- a/dev-lisp/sbcl/ChangeLog
+++ b/dev-lisp/sbcl/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for dev-lisp/sbcl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.215 2015/01/31 04:35:14 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/ChangeLog,v 1.216 2015/02/01 01:46:12 gienah Exp $
+
+ 01 Feb 2015; Mark Wright <gienah@gentoo.org>
+ +files/sbcl-1.0.55-newglibc.patch, sbcl-1.0.55-r1.ebuild:
+ Fix Bug 463882 - dev-lisp/sbcl-1.0.55-r1 - x86-64-linux-os.c:93:1: error:
+ REG_RAX undeclared (first use in this function). Thanks to Bernardo Costa for
+ reporting, Coacher for supplying the pointer to the patch from upstream that
+ is applied to fix the problem, Juergen Rose and Guenther Brunthaler for
+ supplying build logs, Vasiliy, Nuno Silva, patrick, blueboar, jer, pchrist and
+ tomwij for helping. Apply fix for Bug 526194 - dev-lisp/sbcl-1.2.4 does not
+ respect CFLAGS and LDFLAGS to sbcl-1.0.55-r1
31 Jan 2015; Mark Wright <gienah@gentoo.org>
+files/sbcl-1.2.7-verbose-build.patch, sbcl-1.2.7.ebuild:
diff --git a/dev-lisp/sbcl/files/sbcl-1.0.55-newglibc.patch b/dev-lisp/sbcl/files/sbcl-1.0.55-newglibc.patch
new file mode 100644
index 000000000000..dbc94b06d4c9
--- /dev/null
+++ b/dev-lisp/sbcl/files/sbcl-1.0.55-newglibc.patch
@@ -0,0 +1,43 @@
+Fixes for glibc 2.17.
+
+linux-os.c is just a missing header (for personality()).
+
+In x86-64-linux-os.c, __USE_GNU is a glibc-internal name that features.h
+defines; _GNU_SOURCE is what it should actually be using to get GNU extensions.
+
+diff -x config.log -x config.status -ru tmp/sbcl-1.1.2/src/runtime/linux-os.c work/sbcl-1.1.2/src/runtime/linux-os.c
+--- tmp/sbcl-1.1.2/src/runtime/linux-os.c 2012-12-01 11:32:38.000000000 +0000
++++ work/sbcl-1.1.2/src/runtime/linux-os.c 2012-12-31 01:20:37.619000000 +0000
+@@ -46,6 +46,7 @@
+ #include <sys/stat.h>
+ #include <unistd.h>
+ #include <linux/version.h>
++#include <sys/personality.h>
+
+ #include "validate.h"
+ #include "thread.h"
+diff -x config.log -x config.status -ru tmp/sbcl-1.1.2/src/runtime/x86-64-linux-os.c work/sbcl-1.1.2/src/runtime/x86-64-linux-os.c
+--- tmp/sbcl-1.1.2/src/runtime/x86-64-linux-os.c 2012-12-01 11:32:38.000000000 +0000
++++ work/sbcl-1.1.2/src/runtime/x86-64-linux-os.c 2012-12-31 01:20:25.450000000 +0000
+@@ -14,6 +14,9 @@
+ * files for more information.
+ */
+
++/* This is to get REG_RAX etc. from sys/ucontext.h. */
++#define _GNU_SOURCE
++
+ #include <stdio.h>
+ #include <stddef.h>
+ #include <sys/param.h>
+@@ -21,11 +24,7 @@
+ #include <sys/types.h>
+ #include <unistd.h>
+ #include <errno.h>
+-
+-#define __USE_GNU
+ #include <sys/ucontext.h>
+-#undef __USE_GNU
+-
+
+ #include "./signal.h"
+ #include "os.h"
diff --git a/dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild b/dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild
index 30d0727be403..9dc284731278 100644
--- a/dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild
+++ b/dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild,v 1.9 2014/08/05 12:47:08 gienah Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lisp/sbcl/sbcl-1.0.55-r1.ebuild,v 1.10 2015/02/01 01:46:12 gienah Exp $
EAPI=3
inherit multilib eutils flag-o-matic pax-utils
@@ -85,6 +85,14 @@ src_prepare() {
epatch "${FILESDIR}"/gentoo-fix_nopie_for_hardened_toolchain.patch
fi
+ # bug #463882, patch from upstream https://bugs.launchpad.net/sbcl/+bug/1095036
+ epatch "${FILESDIR}"/${P}-newglibc.patch
+
+ # bug #526194
+ sed -e "s@CFLAGS =@CFLAGS = ${CFLAGS}@" \
+ -e "s@LINKFLAGS =@LINKFLAGS = ${LDFLAGS}@" \
+ -i src/runtime/GNUmakefile || die
+
use source && sed 's%"$(BUILD_ROOT)%$(MODULE).lisp "$(BUILD_ROOT)%' -i contrib/vanilla-module.mk
# Some shells(such as dash) don't have "time" as builtin