summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/adodb/adodb-4.51.ebuild')
-rw-r--r--dev-php/adodb/adodb-4.51.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-php/adodb/adodb-4.51.ebuild b/dev-php/adodb/adodb-4.51.ebuild
new file mode 100644
index 000000000000..f9d0aad63af5
--- /dev/null
+++ b/dev-php/adodb/adodb-4.51.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-php/adodb/adodb-4.51.ebuild,v 1.1 2004/08/02 13:44:21 pfeifer Exp $
+
+inherit php-lib
+
+DESCRIPTION="Active Data Objects Data Base library for PHP"
+HOMEPAGE="http://adodb.sourceforge.net/"
+MY_P=${PN}${PV//./}
+SRC_URI="mirror://sourceforge/adodb/${MY_P}.tgz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=">=virtual/php-4.0.5"
+S="${WORKDIR}/${PN}"
+
+pkg_setup() {
+ ewarn "ADODB requires some form of SQL or ODBC support in your PHP."
+}
+
+src_install() {
+ # install php files
+ php-lib_src_install . `find . -name '*.php'`
+
+ # install xsl files
+ insinto /usr/lib/php/adodb/xsl
+ doins xsl/*.xsl
+
+ # install documentation
+ dohtml docs/*.htm
+ dodoc *.txt xmlschema.dtd session/adodb-sess.txt pear/readme.Auth.txt
+}