summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-php/php-cgi/php-cgi-4.3.9-r1.ebuild')
-rw-r--r--dev-php/php-cgi/php-cgi-4.3.9-r1.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-php/php-cgi/php-cgi-4.3.9-r1.ebuild b/dev-php/php-cgi/php-cgi-4.3.9-r1.ebuild
deleted file mode 100644
index d9010a8b206e..000000000000
--- a/dev-php/php-cgi/php-cgi-4.3.9-r1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-php/php-cgi/php-cgi-4.3.9-r1.ebuild,v 1.4 2005/05/19 20:25:58 robbat2 Exp $
-
-PHPSAPI="cgi"
-inherit php-sapi eutils
-
-DESCRIPTION="PHP CGI"
-SLOT="0"
-KEYWORDS="x86 sparc alpha hppa ppc ia64"
-
-# for this revision only
-PDEPEND=">=${PHP_PROVIDER_PKG}-4.3.9"
-PROVIDE="${PROVIDE} virtual/httpd-php"
-
-src_compile() {
- # CLI needed to build stuff
- myconf="${myconf} \
- --enable-cgi \
- --enable-cli \
- --enable-fastcgi"
-
- php-sapi_src_compile
-}
-
-src_install() {
- PHP_INSTALLTARGETS="install"
- php-sapi_src_install
-
- rm -f ${D}/usr/bin/php
- # rename binary
- newbin ${S}/sapi/cgi/php php-cgi
-}
-
-pkg_postinst() {
- php-sapi_pkg_postinst
- einfo "This is a CGI only build."
-}