summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/tabulate')
-rw-r--r--dev-python/tabulate/ChangeLog9
-rw-r--r--dev-python/tabulate/tabulate-0.7.3.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/tabulate/ChangeLog b/dev-python/tabulate/ChangeLog
index f68f860c4b47..19a4550c905c 100644
--- a/dev-python/tabulate/ChangeLog
+++ b/dev-python/tabulate/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/tabulate
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/tabulate/ChangeLog,v 1.1 2014/06/04 09:50:55 jlec Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tabulate/ChangeLog,v 1.2 2015/01/26 07:53:31 jlec Exp $
+
+*tabulate-0.7.3 (26 Jan 2015)
+
+ 26 Jan 2015; Justin Lecher <jlec@gentoo.org> +tabulate-0.7.3.ebuild:
+ Version Bump
*tabulate-0.7.2 (04 Jun 2014)
diff --git a/dev-python/tabulate/tabulate-0.7.3.ebuild b/dev-python/tabulate/tabulate-0.7.3.ebuild
new file mode 100644
index 000000000000..938126e5db5c
--- /dev/null
+++ b/dev-python/tabulate/tabulate-0.7.3.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/tabulate/tabulate-0.7.3.ebuild,v 1.1 2015/01/26 07:53:31 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python{3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pretty-print tabular data"
+HOMEPAGE="https://pypi.python.org/pypi/tabulate"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ test? ( virtual/funcsigs[${PYTHON_USEDEP}] )
+"
+
+# Missing something:
+#
+# from common import assert_equal
+RESTRICT=test
+
+python_test() {
+ local testcase
+ for testcase in test/*py; do
+ ${PYTHON} ${testcase} || die
+ done
+}