summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/wiggle')
-rw-r--r--dev-util/wiggle/wiggle-0.6-r1.ebuild38
-rw-r--r--dev-util/wiggle/wiggle-0.6.ebuild42
2 files changed, 32 insertions, 48 deletions
diff --git a/dev-util/wiggle/wiggle-0.6-r1.ebuild b/dev-util/wiggle/wiggle-0.6-r1.ebuild
index 308417a1eb74..c3de832b7ad3 100644
--- a/dev-util/wiggle/wiggle-0.6-r1.ebuild
+++ b/dev-util/wiggle/wiggle-0.6-r1.ebuild
@@ -1,42 +1,37 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6-r1.ebuild,v 1.1 2004/06/28 07:07:03 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6-r1.ebuild,v 1.2 2004/06/28 20:05:55 vapier Exp $
inherit eutils
-IUSE=""
-
-S=${WORKDIR}/${P}
-
PATCHDATE=20040627
PATCHBALL=${P}-patches-${PATCHDATE}
-
-DESCRIPTION="Wiggle is a program for applying patches that patch cannot apply because of conflicting changes"
+DESCRIPTION="program for applying patches that patch cannot apply because of conflicting changes"
HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/"
SRC_URI="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/${P}.tar.gz
mirror://gentoo/${PATCHBALL}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="~x86"
+IUSE=""
# The 'p' tool does support bitkeeper, but I'm against just dumping it in here
# due to it's size. I've explictly listed every other dependancy here due to
# the nature of the shell program 'p'
RDEPEND="dev-util/diffstat
- dev-util/patchutils
- sys-apps/diffutils
- sys-apps/findutils
- sys-apps/gawk
- sys-apps/grep
- sys-apps/less
- sys-apps/sed
- sys-apps/coreutils
- sys-devel/patch"
-
+ dev-util/patchutils
+ sys-apps/diffutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/less
+ sys-apps/sed
+ sys-apps/coreutils
+ sys-devel/patch"
DEPEND="${RDEPEND}
- sys-apps/groff
- sys-apps/time"
+ sys-apps/groff
+ sys-apps/time"
PATCHLIST="001NoQuietTime 002SpecFile 003Recommit 004ExtractFix 005Pchanges"
@@ -56,7 +51,6 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- into /usr
dobin p
- dodoc ANNOUNCE COPYING INSTALL TODO DOC/diff.ps p.help notes
+ dodoc ANNOUNCE INSTALL TODO DOC/diff.ps p.help notes
}
diff --git a/dev-util/wiggle/wiggle-0.6.ebuild b/dev-util/wiggle/wiggle-0.6.ebuild
index 44873619e56a..782ebd97b92a 100644
--- a/dev-util/wiggle/wiggle-0.6.ebuild
+++ b/dev-util/wiggle/wiggle-0.6.ebuild
@@ -1,45 +1,36 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6.ebuild,v 1.5 2004/06/25 02:50:35 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/wiggle/wiggle-0.6.ebuild,v 1.6 2004/06/28 20:05:55 vapier Exp $
inherit eutils
-IUSE=""
-
-S=${WORKDIR}/${P}
-
PATCHDATE=20030611
PATCHBALL=${P}-patches-${PATCHDATE}
-
-DESCRIPTION="Wiggle is a program for applying patches that patch cannot apply because of conflicting changes"
+DESCRIPTION="program for applying patches that patch cannot apply because of conflicting changes"
HOMEPAGE="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/"
SRC_URI="http://cgi.cse.unsw.edu.au/~neilb/source/wiggle/${P}.tar.gz
mirror://gentoo/${PATCHBALL}.tar.bz2"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="x86"
-
+IUSE=""
# The 'p' tool does support bitkeeper, but I'm against just dumping it in here due to it's size.
# I've explictly listed every other dependancy here due to the nature of the shell program 'p'
RDEPEND="dev-util/diffstat
- dev-util/patchutils
- sys-apps/diffutils
- sys-apps/fileutils
- sys-apps/findutils
- sys-apps/gawk
- sys-apps/grep
- sys-apps/less
- sys-apps/sed
- sys-apps/sh-utils
- sys-apps/textutils
- sys-devel/patch"
-
+ dev-util/patchutils
+ sys-apps/diffutils
+ sys-apps/coreutils
+ sys-apps/findutils
+ sys-apps/gawk
+ sys-apps/grep
+ sys-apps/less
+ sys-apps/sed
+ sys-devel/patch"
DEPEND="${RDEPEND}
- sys-apps/groff
- sys-apps/time"
-
+ sys-apps/groff
+ sys-apps/time"
PATCHLIST="001NoQuietTime 002SpecFile 003Recommit"
@@ -59,7 +50,6 @@ src_compile() {
src_install() {
make DESTDIR=${D} install || die
- into /usr
dobin p
- dodoc ANNOUNCE COPYING INSTALL TODO DOC/diff.ps p.help notes
+ dodoc ANNOUNCE INSTALL TODO DOC/diff.ps p.help notes
}