summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/libconf/ChangeLog6
-rw-r--r--dev-util/libconf/libconf-0.42.10.ebuild26
2 files changed, 27 insertions, 5 deletions
diff --git a/dev-util/libconf/ChangeLog b/dev-util/libconf/ChangeLog
index 6ac0547a2520..9aeacd3d894f 100644
--- a/dev-util/libconf/ChangeLog
+++ b/dev-util/libconf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/libconf
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/ChangeLog,v 1.37 2005/11/23 10:50:32 metalgod Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/ChangeLog,v 1.38 2005/11/26 17:39:13 slarti Exp $
+
+ 26 Nov 2005; Tom Martin <slarti@gentoo.org> libconf-0.42.10.ebuild:
+ Multilib fix -- ebuild will install to a multilib-strict environment now.
+ Also, remove call to make check in src_compile.
23 Nov 2005; Luis Medinas <metalgod@gentoo.org> libconf-0.40.00.ebuild:
Stable on amd64. Fixing bug #113291.
diff --git a/dev-util/libconf/libconf-0.42.10.ebuild b/dev-util/libconf/libconf-0.42.10.ebuild
index a1ce0781675d..e22109e97060 100644
--- a/dev-util/libconf/libconf-0.42.10.ebuild
+++ b/dev-util/libconf/libconf-0.42.10.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.42.10.ebuild,v 1.1 2005/11/22 17:34:38 dams Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/libconf/libconf-0.42.10.ebuild,v 1.2 2005/11/26 17:39:13 slarti Exp $
+
+inherit multilib
MY_P=perl-${PN/l/L}-${PV}
S=${WORKDIR}/${MY_P}
@@ -19,19 +21,35 @@ dev-perl/XML-Twig
python? ( >=dev-lang/python-2.4.2 )
ruby? ( >=dev-lang/ruby-1.8.3 )"
-if use python; then
+if use python ; then
mypython="python"
fi
-if use ruby; then
+if use ruby ; then
myruby="ruby"
fi
mybindings="c ${mypython} ${myruby} bash";
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # Multilib fix
+ sed -i "/^LIB_DIR/ { s:lib:$(get_libdir): }" \
+ bindings/c/src/Makefile \
+ || die "bad sed"
+}
src_compile() {
emake "BINDINGS=${mybindings}" || die "make failed"
- make "BINDINGS=${mybindings}" test || die "make test failed"
+
+ # Multilib fix. Needs to be in src_compile because we need to tweak the
+ # Makefile that's generated by extconf.rb. More elegant solution?
+ if use ruby ; then
+ sed -i "/^sitedir/ { s:lib:$(get_libdir): }" \
+ bindings/ruby/src/Makefile \
+ || die "bad sed"
+ fi
}
src_install() {