summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/cssc/ChangeLog5
-rw-r--r--dev-vcs/cssc/cssc-1.2.0.ebuild31
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-vcs/cssc/ChangeLog b/dev-vcs/cssc/ChangeLog
index a0c9b087a69b..7675a3c1295e 100644
--- a/dev-vcs/cssc/ChangeLog
+++ b/dev-vcs/cssc/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/cssc
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/ChangeLog,v 1.7 2011/01/08 18:26:10 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/ChangeLog,v 1.8 2011/01/08 18:29:03 jer Exp $
+
+ 08 Jan 2011; Jeroen Roovers <jer@gentoo.org> +cssc-1.2.0.ebuild:
+ Oops, should not have removed that.
08 Jan 2011; Jeroen Roovers <jer@gentoo.org> -cssc-1.2.0.ebuild,
cssc-1.3.0.ebuild:
diff --git a/dev-vcs/cssc/cssc-1.2.0.ebuild b/dev-vcs/cssc/cssc-1.2.0.ebuild
new file mode 100644
index 000000000000..bf83b07c5377
--- /dev/null
+++ b/dev-vcs/cssc/cssc-1.2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cssc/cssc-1.2.0.ebuild,v 1.6 2011/01/08 18:29:02 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="CSSC is the GNU Project's replacement for SCCS"
+SRC_URI="mirror://gnu/${PN}/CSSC-${PV}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/cssc/"
+SLOT="0"
+LICENSE="GPL-3"
+S=${WORKDIR}/CSSC-${PV}
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE=""
+
+src_prepare() {
+ # The large test takes a long time
+ sed -i tests/Makefile.* \
+ -e 's|\([[:space:]]\)test-large |\1|g' || die "sed failed"
+}
+
+src_configure() { econf --enable-binary; }
+
+src_compile() {
+ emake all || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README NEWS ChangeLog AUTHORS || die "dodoc failed"
+}