summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/gxmame/gxmame-0.33.ebuild')
-rw-r--r--games-emulation/gxmame/gxmame-0.33.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/games-emulation/gxmame/gxmame-0.33.ebuild b/games-emulation/gxmame/gxmame-0.33.ebuild
new file mode 100644
index 000000000000..cf2f62e0da9c
--- /dev/null
+++ b/games-emulation/gxmame/gxmame-0.33.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gxmame/gxmame-0.33.ebuild,v 1.1 2003/09/09 16:26:50 vapier Exp $
+
+DESCRIPTION="frontend for XMame using the GTK library"
+HOMEPAGE="http://gxmame.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE="nls"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1.2*
+ =dev-libs/glib-1.2*
+ media-libs/gdk-pixbuf"
+RDEPEND="nls? ( sys-devel/gettext )
+ app-emulation/xmame"
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ make install DESTDIR=${D} || die
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}