summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff')
-rw-r--r--games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff46
1 files changed, 46 insertions, 0 deletions
diff --git a/games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff b/games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff
new file mode 100644
index 000000000000..73204ae0e3da
--- /dev/null
+++ b/games-emulation/tuxnes/files/configure.in-tuxnes-0.75-gentoo.diff
@@ -0,0 +1,46 @@
+--- tuxnes-0.75/configure.in 2001-04-15 20:08:07.000000000 -0500
++++ tuxnes-0.75-gentoo/configure.in 2002-12-03 00:38:41.000000000 -0500
+@@ -31,7 +31,8 @@
+ dnl Don't assume we want high level optimisations, it is known to
+ dnl produce broken code on certain architectures using certain compilers
+ dnl --------------------------------------------------------------------
+-CFLAGS="-O"
++dnl We'll fix this the Gentoo way
++dnl CFLAGS="-O"
+ AC_SUBST(CFLAGS)
+
+ dnl --------------------------------------------------------------------
+@@ -46,12 +47,12 @@
+ AC_ARG_ENABLE(warnings, [ --enable-warnings enable more compilation warning checks [default=no]], enable_warnings="yes", enable_warnings="no")
+
+ if test "x$enable_warnings" = "xyes"; then
+- CFLAGS="$CFLAGS -pipe -W -Wall -ansi -pedantic -Wbad-function-cast \
++ CFLAGS="$CFLAGS -W -Wall -ansi -pedantic -Wbad-function-cast \
+ -Wcast-align -Wcast-qual -Wchar-subscripts -Wconversion -Winline \
+ -Wmissing-prototypes -Wnested-externs -Wpointer-arith \
+ -Wredundant-decls -Wshadow -Wstrict-prototypes -Wwrite-strings"
+ else
+- CFLAGS="$CFLAGS -pipe -Wall"
++ CFLAGS="$CFLAGS"
+ fi
+ AC_SUBST(CFLAGS)
+
+@@ -144,12 +145,9 @@
+ [ --without-ggi disable check for GGI (General Graphics Interface)])
+
+ if test "x$with_ggi" != "xno"; then
+- OCPPFLAGS="$CPPFLAGS"
+- CPPFLAGS="-I/usr/local/include"
+- AC_CHECK_HEADERS(ggi/gii.h ggi/ggi.h, CFLAGS="$CFLAGS -I/usr/local/include")
++ AC_CHECK_HEADERS(ggi/gii.h ggi/ggi.h)
+ AC_CHECK_LIB(ggi, ggiInit)
+ AC_CHECK_LIB(gii, giiInit)
+- CPPFLAGS="$OCPPFLAGS"
+ fi
+
+ dnl --------------------------------------------------------------------
+@@ -210,3 +208,4 @@
+ AC_CHECK_FUNCS(gettimeofday strtod strtoul)
+
+ AC_OUTPUT(Makefile)
++