summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-misc/fortune-mod/fortune-mod-9708-r1.ebuild')
-rw-r--r--games-misc/fortune-mod/fortune-mod-9708-r1.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/games-misc/fortune-mod/fortune-mod-9708-r1.ebuild b/games-misc/fortune-mod/fortune-mod-9708-r1.ebuild
index 368ac97c4809..71d2f07473d3 100644
--- a/games-misc/fortune-mod/fortune-mod-9708-r1.ebuild
+++ b/games-misc/fortune-mod/fortune-mod-9708-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-9708-r1.ebuild,v 1.3 2004/02/20 06:43:58 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/fortune-mod/fortune-mod-9708-r1.ebuild,v 1.4 2004/05/04 00:21:18 mr_bones_ Exp $
inherit eutils
@@ -17,8 +17,6 @@ IUSE="offensive"
DEPEND="virtual/glibc"
-[ `use offensive` ] && off=1 || off=0
-
pkg_setup() {
einfo "By default the fortune ebuild does not include 'offensive' fortunes."
einfo "If you wish to enable this functionality, you must manually edit the"
@@ -33,6 +31,7 @@ src_unpack() {
}
src_compile() {
+ [ `use offensive` ] && off=1 || off=0
emake \
OFFENSIVE=${off} \
OPTCFLAGS="${CFLAGS}" \
@@ -40,6 +39,7 @@ src_compile() {
}
src_install() {
+ [ `use offensive` ] && off=1 || off=0
make \
OFFENSIVE=${off} \
OPTCFLAGS="${CFLAGS}" \