summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-rpg/pcgen/pcgen-5.16.2.ebuild')
-rw-r--r--games-rpg/pcgen/pcgen-5.16.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/games-rpg/pcgen/pcgen-5.16.2.ebuild b/games-rpg/pcgen/pcgen-5.16.2.ebuild
new file mode 100644
index 000000000000..77519e2d6bde
--- /dev/null
+++ b/games-rpg/pcgen/pcgen-5.16.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/pcgen/pcgen-5.16.2.ebuild,v 1.1 2010/02/19 16:27:57 mr_bones_ Exp $
+
+EAPI=2
+inherit versionator games
+
+MY_PV=$(delete_all_version_separators)
+DESCRIPTION="D&D character generator"
+HOMEPAGE="http://pcgen.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pcgen/pcgen${MY_PV}_full.zip"
+
+LICENSE="LGPL-2 OGL-1.0a"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.5"
+DEPEND="app-arch/unzip"
+
+S=${WORKDIR}/pcgen${MY_PV}
+
+src_prepare() {
+ rm -f *.bat
+ sed -i "/dirname/ c\cd \"${GAMES_DATADIR}\/${PN}\"" pcgen.sh \
+ || die "sed pcgen.sh failed"
+ mv -f pcgen.sh "${T}"/${PN}
+}
+
+src_install() {
+ dogamesbin "${T}"/${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r * || die "doins failed"
+ keepdir "${GAMES_DATADIR}"/${PN}/characters
+ prepgamesdirs
+}