summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-base/libbonoboui/libbonoboui-1.117.0.ebuild')
-rw-r--r--gnome-base/libbonoboui/libbonoboui-1.117.0.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/gnome-base/libbonoboui/libbonoboui-1.117.0.ebuild b/gnome-base/libbonoboui/libbonoboui-1.117.0.ebuild
new file mode 100644
index 000000000000..e99b84a60d9d
--- /dev/null
+++ b/gnome-base/libbonoboui/libbonoboui-1.117.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/libbonoboui/libbonoboui-1.117.0.ebuild,v 1.1 2002/05/23 19:15:17 spider Exp $
+
+# Do _NOT_ strip symbols in the build! Need both lines for Portage 1.8.9+
+DEBUG="yes"
+RESTRICT="nostrip"
+# force debug information
+CFLAGS="${CFLAGS} -g"
+CXXFLAGS="${CXXFLAGS} -g"
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="User Interface part of Lib bonobo"
+SRC_URI="ftp://ftp.gnome.org/pub/GNOME/pre-gnome2/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+
+RDEPEND=">=gnome-base/libglade-1.99.10
+ >=media-libs/libart_lgpl-2.3.8-r1
+ >=gnome-base/libgnome-1.117.1
+ >=gnome-base/libgnomecanvas-1.117.0
+ >=gnome-base/bonobo-activation-0.9.9
+ >=gnome-base/libbonobo-1.117.0
+ >=gnome-base/gconf-1.1.10
+ >=x11-libs/gtk+-2.0.0
+ >=dev-libs/glib-2.0.0"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0
+ >=dev-util/intltool-0.17"
+
+
+src_compile() {
+ local myconf
+ libtoolize --copy --force
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --enable-debug=yes || die "configure failure"
+
+ emake || die "compile failure"
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS COPYING* ChangeLog INSTALL NEWS README
+}
+
+
+
+
+