summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-office/eog')
-rw-r--r--gnome-office/eog/eog-0.6.ebuild31
1 files changed, 19 insertions, 12 deletions
diff --git a/gnome-office/eog/eog-0.6.ebuild b/gnome-office/eog/eog-0.6.ebuild
index c8effe7fca72..9a7dafed81af 100644
--- a/gnome-office/eog/eog-0.6.ebuild
+++ b/gnome-office/eog/eog-0.6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/gnome-office/eog/eog-0.6.ebuild,v 1.2 2001/05/10 09:39:40 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-office/eog/eog-0.6.ebuild,v 1.3 2001/06/05 19:43:20 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -9,20 +9,27 @@ DESCRIPTION="Eye of GNOME"
SRC_URI="ftp://ftp.gnome.org/pub/GNOME/unstable/sources/eog/"${A}
HOMEPAGE="http://www.gnome.org/gnome-office/eog.shtml"
-DEPEND=">=gnome-base/bonobo-0.18
- >=gnome-base/gconf-0.8
- >=gnome-base/gnome-core-1.4
- >=gnome-base/libglade-0.16"
-
-src_compile() {
- try ./configure --host=${CHOST} --prefix=/opt/gnome \
- --with-bonobo
+DEPEND="virtual/glibc nls? ( sys-devel/gettext )
+ >=gnome-base/bonobo-1.0.4
+ >=gnome-base/gconf-1.0.1
+ >=dev-util/xml-i18n-tools-0.8.4"
+
+RDEPEND="virtual/glibc
+ >=gnome-base/gconf-1.0.1
+ >=gnome-base/bonobo-1.0.4"
+
+src_compile() {
+ local myconf
+ if [ -z "`use nls`" ] ; then
+ myconf="--disable-nls"
+ fi
+ try ./configure --host=${CHOST} --prefix=/opt/gnome --sysconfdir=/etc/opt/gnome $myconf
try make
}
-src_install() {
- try make prefix=${D}/opt/gnome \
- GCONG_CONFIG_SOURCE=xml=${D}/opt/gnome/etc/gconf/gconf.xml.defaults install
+src_install() {
+ try make prefix=${D}/opt/gnome sysconfdir=/etc/opt/gnome \
+ GCONG_CONFIG_SOURCE=xml=${D}/etc/opt/gnome/gconf/gconf.xml.defaults install
dodoc AUTHORS COPYING DEPENDS ChangeLog HACKING NEWS README TODO MAINTAINERS
}