summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kdeartwork')
-rw-r--r--kde-base/kdeartwork/files/digest-kdeartwork-3.0.11
-rw-r--r--kde-base/kdeartwork/kdeartwork-3.0.1.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/kde-base/kdeartwork/files/digest-kdeartwork-3.0.1 b/kde-base/kdeartwork/files/digest-kdeartwork-3.0.1
new file mode 100644
index 000000000000..028b68a08252
--- /dev/null
+++ b/kde-base/kdeartwork/files/digest-kdeartwork-3.0.1
@@ -0,0 +1 @@
+MD5 87ca9fbac6a97b6aa0689f53fca41565 kdeartwork-3.0.1.tar.bz2 10917073
diff --git a/kde-base/kdeartwork/kdeartwork-3.0.1.ebuild b/kde-base/kdeartwork/kdeartwork-3.0.1.ebuild
new file mode 100644
index 000000000000..c3a40db93e82
--- /dev/null
+++ b/kde-base/kdeartwork/kdeartwork-3.0.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Dan Armak <danarmak@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeartwork/kdeartwork-3.0.1.ebuild,v 1.1 2002/05/13 19:42:32 danarmak Exp $
+. /usr/portage/eclass/inherit.eclass || die
+inherit kde-dist
+
+newdepend "opengl? ( virtual/opengl )"
+
+DESCRIPTION="${DESCRIPTION}Artwork"
+
+myconf="$myconf --with-dpms"
+use opengl && myconf="$myconf --with-gl" || myconf="$myconf --without-gl"
+
+src_unpack() {
+
+ base_src_unpack
+
+ cd ${S}
+ # added to fix GL problems within xscreensavers
+ patch -p1 < ${FILESDIR}/kdeartwork-screensaver.patch
+
+}
+
+src_install() {
+ dodir ${KDEDIR}/share/apps/kthememgr/Themes
+ kde_src_install all
+}