summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/krfb/krfb-4.11.5.ebuild')
-rw-r--r--kde-base/krfb/krfb-4.11.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/kde-base/krfb/krfb-4.11.5.ebuild b/kde-base/krfb/krfb-4.11.5.ebuild
new file mode 100644
index 000000000000..90a456ca3419
--- /dev/null
+++ b/kde-base/krfb/krfb-4.11.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/krfb/krfb-4.11.5.ebuild,v 1.1 2014/01/10 04:21:50 creffett Exp $
+
+EAPI=5
+
+KDE_HANDBOOK="optional"
+inherit kde4-base
+
+DESCRIPTION="VNC-compatible server to share KDE desktops"
+HOMEPAGE="http://www.kde.org/applications/system/krfb/"
+KEYWORDS=" ~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug telepathy"
+
+DEPEND="
+ sys-libs/zlib
+ virtual/jpeg:0
+ !aqua? (
+ x11-libs/libX11
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXtst
+ )
+ telepathy? ( >=net-libs/telepathy-qt-0.9 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with telepathy TelepathyQt4)
+ )
+
+ kde4-base_src_configure
+}