summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base')
-rw-r--r--kde-base/kdeedu/ChangeLog7
-rw-r--r--kde-base/kdeedu/kdeedu-3.5.9.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kdeedu/ChangeLog b/kde-base/kdeedu/ChangeLog
index 5009df51371c..3c6b0f8109ee 100644
--- a/kde-base/kdeedu/ChangeLog
+++ b/kde-base/kdeedu/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeedu
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/ChangeLog,v 1.235 2008/02/18 23:56:05 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/ChangeLog,v 1.236 2008/02/20 22:48:30 philantrop Exp $
+
+*kdeedu-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org> +kdeedu-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
18 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
-files/kstars-4.0.0-destdir.patch, -files/marble-4.0.0-fix-tests.patch,
diff --git a/kde-base/kdeedu/kdeedu-3.5.9.ebuild b/kde-base/kdeedu/kdeedu-3.5.9.ebuild
new file mode 100644
index 000000000000..7661f4ba2bbc
--- /dev/null
+++ b/kde-base/kdeedu/kdeedu-3.5.9.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeedu/kdeedu-3.5.9.ebuild,v 1.1 2008/02/20 22:48:30 philantrop Exp $
+
+EAPI="1"
+inherit kde-dist eutils
+
+DESCRIPTION="KDE educational apps"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kig-scripting solver"
+
+DEPEND="kig-scripting? ( >=dev-libs/boost-1.32 )
+ solver? ( >=dev-ml/facile-1.1 )"
+
+pkg_setup() {
+ if use solver && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-lang/ocaml built with the ocamlopt useflag"
+ eerror "in order to get a native code ocaml compiler"
+ die "Please install dev-lang/ocaml with ocamlopt support"
+ fi
+ if use solver && ! built_with_use --missing true dev-ml/facile ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-ml/facile built with the ocamlopt useflag"
+ eerror "in order to get the native code library"
+ die "Please install dev-ml/facile with ocamlopt support"
+ fi
+ kde_pkg_setup
+}
+
+src_unpack() {
+ kde_src_unpack
+
+ # Fix ktouch's desktop file
+ sed -i -e "s:\(Categories=.*\)Miscellaneous;:\1:" "${S}/ktouch/ktouch.desktop"
+}
+
+src_compile() {
+ local myconf="$(use_enable kig-scripting kig-python-scripting)
+ $(use_enable solver ocamlsolver)"
+
+ kde_src_compile
+}