summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libdsp/libdsp-4.9.2.ebuild')
-rw-r--r--media-libs/libdsp/libdsp-4.9.2.ebuild12
1 files changed, 3 insertions, 9 deletions
diff --git a/media-libs/libdsp/libdsp-4.9.2.ebuild b/media-libs/libdsp/libdsp-4.9.2.ebuild
index de5c85bdb41e..2a56b66ae054 100644
--- a/media-libs/libdsp/libdsp-4.9.2.ebuild
+++ b/media-libs/libdsp/libdsp-4.9.2.ebuild
@@ -1,8 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2.ebuild,v 1.2 2005/01/09 11:11:15 swegener Exp $
-
-IUSE="doc"
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libdsp/libdsp-4.9.2.ebuild,v 1.3 2005/07/13 14:25:11 swegener Exp $
inherit eutils
@@ -13,16 +11,12 @@ SRC_URI="mirror://sourceforge/${PN}/${PN}-src-${PV}.tar.gz
LICENSE="GPL-2"
SLOT="0"
+IUSE="doc"
KEYWORDS="~x86"
DEPEND=""
S=${WORKDIR}/${PN}-src-${PV}
-src_unpack() {
- unpack ${A}
- cd ${S}
-}
-
src_compile() {
# fixes some Makefile weirdness
epatch ${FILESDIR}/Makefile.patch
@@ -36,7 +30,7 @@ src_compile() {
sed -e "s:^PREFIX.*:PREFIX = ${D}/usr:" -i DynThreads/Makefile
# libtool only supports the --tag option from v1.5 onwards
- if ! has_version >= sys-devel/libtool-1.5.0; then
+ if ! has_version ">=sys-devel/libtool-1.5.0"; then
sed -e "s/^LIBTOOL = libtool --tag=CXX/LIBTOOL = libtool/" -i libDSP/Makefile
fi