summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libswf/libswf-0.99.ebuild')
-rw-r--r--media-libs/libswf/libswf-0.99.ebuild52
1 files changed, 35 insertions, 17 deletions
diff --git a/media-libs/libswf/libswf-0.99.ebuild b/media-libs/libswf/libswf-0.99.ebuild
index e7f57515fe9d..e9797de1d46e 100644
--- a/media-libs/libswf/libswf-0.99.ebuild
+++ b/media-libs/libswf/libswf-0.99.ebuild
@@ -1,26 +1,44 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Your Name <your email>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libswf/libswf-0.99.ebuild,v 1.1 2001/07/03 16:52:07 achim Exp $
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libswf/libswf-0.99.ebuild,v 1.1.1.1 2005/11/30 10:04:06 chriswhite Exp $
+
+inherit multilib
S=${WORKDIR}/dist
DESCRIPTION="A library for flash movies"
SRC_URI="http://reality.sgi.com/grafica/flash/dist.99.linux.tar.Z"
-HOMEPAGE="http://reality.sgi.com/grafica/flash/"
+HOMEPAGE="ftp://ftp.sgi.com/sgi/graphics/grafica/flash/index.html"
-DEPEND="virtual/glibc"
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86 -sparc -ppc -hppa -mips amd64"
+IUSE=""
-src_install () {
+pkg_config() {
+ has_multilib_profile && ABI="x86"
+}
+
+DEPEND="virtual/libc
+ app-arch/unzip"
- dolib.a libswf.a
- dobin bin/*
- insinto /usr/include
- doins swf.h
- insinto /usr/share/swf/fonts
- doins fonts/*
- insinto /usr/share/swf/psfonts
- doins psfonts/*
- docinto html
- dodoc *.html
+src_unpack () {
+ unpack ${A}
+ if [ -f dist.99.linux.tar ]; then
+ tar -xf dist.99.linux.tar
+ fi
+ cd ${S}
+ sed -e 's:\tswftest:\t./swftest:' -i Makefile || die "sed failed"
}
+src_install () {
+
+ dolib.a libswf.a
+ dobin bin/*
+ insinto /usr/include
+ doins swf.h
+ insinto /usr/share/swf/fonts
+ doins fonts/*
+ insinto /usr/share/swf/psfonts
+ doins psfonts/*
+ dohtml *.html
+}