summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/xmms-arts/xmms-arts-0.4-r5.ebuild')
-rw-r--r--media-plugins/xmms-arts/xmms-arts-0.4-r5.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/media-plugins/xmms-arts/xmms-arts-0.4-r5.ebuild b/media-plugins/xmms-arts/xmms-arts-0.4-r5.ebuild
new file mode 100644
index 000000000000..4100c802925a
--- /dev/null
+++ b/media-plugins/xmms-arts/xmms-arts-0.4-r5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-plugins/xmms-arts/xmms-arts-0.4-r5.ebuild,v 1.1 2002/10/25 18:47:08 lostlogic Exp $
+inherit kde-base libtool
+
+# Note: we set many vars e.g. DEPEND insteaed of extending them because this isn't a proper KDE app,
+# it only links against arts. So we need set-kdedir, but almost nothing else. So make sure it continues
+# to override e.g. src_install.
+
+DESCRIPTION="This output plugin allows xmms to work with arts, KDE's sound system"
+SRC_URI="http://stukach.com/hosted/m.i.a/xmmsarts/xmmsarts-0.4.tar.gz"
+# HOMEPAGE="http://home.earthlink.net/~bheath/xmms-arts/" #disappeared from the 'net?
+HOMEPAGE="http://www.xmms.org/plugins_output.html"
+
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+newdepend ">=media-sound/xmms-1.2.5-r1
+ kde-base/arts"
+
+set-kdedir 3
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ patch -p2 < ${FILESDIR}/${PN/-/}-${PV}-nocmallocc.patch || die "Failed patch"
+ cp Makefile.am Makefile.orig
+ sed -e "s:artsc-config:${KDEDIR}/bin/artsc-config:" \
+ Makefile.orig > Makefile.am
+ patch -p1 < ${FILESDIR}/${P}-gentoo.patch || die "Failed patch"
+ autoconf
+ patch -p1 < ${FILESDIR}/${P}-gentoo-endian.patch || die "Failed patch"
+}
+
+src_compile() {
+ elibtoolize
+
+ kde_src_compile myconf # calls set-kdedir
+ CFLAGS="$CFLAGS -I/usr/X11R6/include -I/usr/include -I${KDEDIR}/include -I${KDEDIR}/include/artsc"
+ econf || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS COPYING NEWS README
+}
+