summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild')
-rw-r--r--media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild54
1 files changed, 27 insertions, 27 deletions
diff --git a/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild b/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild
index 2a677c28c05a..5685c310a0d3 100644
--- a/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild
+++ b/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild,v 1.7 2003/06/16 22:28:48 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/alsa-tools/alsa-tools-0.9.0_rc1-r1.ebuild,v 1.8 2003/09/11 01:21:31 msterret Exp $
S="${WORKDIR}/${P/_rc/rc}"
DESCRIPTION="Advanced Linux Sound Architecture tools"
@@ -18,35 +18,35 @@ DEPEND=">=media-libs/alsa-lib-0.9.0_rc1
ALSA_TOOLS="ac3dec as10k1 envy24control sb16_csp seq/sbiload"
src_compile() {
- # Some of the tools don't make proper use of CFLAGS, even though
- # all of them seem to use autoconf. This needs to be fixed.
- local f
- for f in ${ALSA_TOOLS}
- do
- cd "${S}/${f}"
-
- econf || die "./configure failed"
- emake || die "Parallel Make Failed"
- done
+ # Some of the tools don't make proper use of CFLAGS, even though
+ # all of them seem to use autoconf. This needs to be fixed.
+ local f
+ for f in ${ALSA_TOOLS}
+ do
+ cd "${S}/${f}"
+
+ econf || die "./configure failed"
+ emake || die "Parallel Make Failed"
+ done
}
src_install() {
- local f
- for f in ${ALSA_TOOLS}
- do
- # Install the main stuff
- cd "${S}/${f}"
- make DESTDIR="${D}" install || die
-
- # Install the text documentation
- local doc
- for doc in README TODO ChangeLog COPYING AUTHORS
+ local f
+ for f in ${ALSA_TOOLS}
do
- if [ -f "${doc}" ]
- then
- mv "${doc}" "${doc}.`basename ${f}`"
- dodoc "${doc}.`basename ${f}`"
- fi
+ # Install the main stuff
+ cd "${S}/${f}"
+ make DESTDIR="${D}" install || die
+
+ # Install the text documentation
+ local doc
+ for doc in README TODO ChangeLog COPYING AUTHORS
+ do
+ if [ -f "${doc}" ]
+ then
+ mv "${doc}" "${doc}.`basename ${f}`"
+ dodoc "${doc}.`basename ${f}`"
+ fi
+ done
done
- done
}