summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/festival/files/festival-1.4.2.patch')
-rw-r--r--media-sound/festival/files/festival-1.4.2.patch174
1 files changed, 174 insertions, 0 deletions
diff --git a/media-sound/festival/files/festival-1.4.2.patch b/media-sound/festival/files/festival-1.4.2.patch
new file mode 100644
index 000000000000..db804401c95d
--- /dev/null
+++ b/media-sound/festival/files/festival-1.4.2.patch
@@ -0,0 +1,174 @@
+--- speech_tools/configure.in.orig 2001-06-18 19:21:34.000000000 -0400
++++ speech_tools/configure.in 2002-08-25 18:06:17.000000000 -0400
+@@ -42,6 +42,9 @@
+
+ AC_C_BIGENDIAN
+
++AC_CHECK_LIB(termcap, tputs, [TERMCAPLIB=-ltermcap], [TERMCAPLIB=-lncurses])
++AC_SUBST(TERMCAPLIB)
++
+ dnl Which version of GCC do we have here
+ COMPILERTYPE=gcc
+ AC_TRY_COMPILE([#include <stdio.h>],
+@@ -52,11 +55,23 @@
+ [COMPILERTYPE=gcc295])
+ AC_TRY_COMPILE([#include <stdio.h>],
+ [int j=
+- #if __GNUC__ == 3
++ #if __GNUC__ == 3 && __GNUC_MINOR__ == 0
+ 3;
+ #endif ],
+ [COMPILERTYPE=gcc30])
+ AC_TRY_COMPILE([#include <stdio.h>],
++ [int j=
++ #if __GNUC__ == 3 && __GNUC_MINOR__ == 1
++ 3;
++ #endif ],
++ [COMPILERTYPE=gcc31])
++AC_TRY_COMPILE([#include <stdio.h>],
++ [int j=
++ #if __GNUC__ == 3
++ 3;
++ #endif ],
++ [COMPILERTYPE=gcc32])
++AC_TRY_COMPILE([#include <stdio.h>],
+ [ int j=
+ #if __GNUC__ == 2 && __GNUC_MINOR__ == 96
+ 3;
+--- speech_tools/config/compilers/Makefile.orig 2001-06-18 19:13:27.000000000 -0400
++++ speech_tools/config/compilers/Makefile 2002-08-25 18:07:11.000000000 -0400
+@@ -41,7 +41,7 @@
+ egcs.mak gcc27emx.mak \
+ suncc.mak suncc40.mak \
+ jolt.mak jdk.mak jdk12.mak none.mak \
+- jikes.mak gcc296.mak gcc30.mak
++ jikes.mak gcc296.mak gcc30.mak gcc31.mak gcc32.mak
+
+ FILES = Makefile $(COMPILERS) gcc_defaults.mak suncc_defaults.mak jdk_defaults.mak jikes_defaults.mak
+
+--- speech_tools/config/compilers/gcc31.mak.orig 2002-09-27 21:18:49.000000000 -0400
++++ speech_tools/config/compilers/gcc31.mak 2002-08-25 18:07:45.000000000 -0400
+@@ -0,0 +1,60 @@
++ ###########################################################################
++ ## ##
++ ## Centre for Speech Technology Research ##
++ ## University of Edinburgh, UK ##
++ ## Copyright (c) 1999 ##
++ ## All Rights Reserved. ##
++ ## ##
++ ## Permission is hereby granted, free of charge, to use and distribute ##
++ ## this software and its documentation without restriction, including ##
++ ## without limitation the rights to use, copy, modify, merge, publish, ##
++ ## distribute, sublicense, and/or sell copies of this work, and to ##
++ ## permit persons to whom this work is furnished to do so, subject to ##
++ ## the following conditions: ##
++ ## 1. The code must retain the above copyright notice, this list of ##
++ ## conditions and the following disclaimer. ##
++ ## 2. Any modifications must be clearly marked as such. ##
++ ## 3. Original authors' names are not deleted. ##
++ ## 4. The authors' names are not used to endorse or promote products ##
++ ## derived from this software without specific prior written ##
++ ## permission. ##
++ ## ##
++ ## THE UNIVERSITY OF EDINBURGH AND THE CONTRIBUTORS TO THIS WORK ##
++ ## DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ##
++ ## ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT ##
++ ## SHALL THE UNIVERSITY OF EDINBURGH NOR THE CONTRIBUTORS BE LIABLE ##
++ ## FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES ##
++ ## WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN ##
++ ## AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ##
++ ## ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF ##
++ ## THIS SOFTWARE. ##
++ ## ##
++ ###########################################################################
++ ## ##
++ ## Author: Alan W Black (awb@cs.cmu.edu) ##
++ ## Date: Sun Aug 25 2002 ##
++ ## -------------------------------------------------------------------- ##
++ ## Settings for GCC-3.1 ##
++ ## ##
++ ###########################################################################
++
++include $(EST)/config/compilers/gcc_defaults.mak
++
++COMPILER_DESC=gcc-3.1
++
++ifndef GCC31
++ GCC31 = gcc
++endif
++
++CC= $(GCC31)
++CXX = $(GCC31)
++
++WARN_CXXFLAGS += -Wno-non-template-friend
++
++STATIC_LINKFLAGS = -Dstatic
++
++COMPILERLIBS= $(COMPILER_LIBS_DIR:%=-L%) -lstdc++
++
++
++
++
+--- speech_tools/config/compilers/gcc32.mak.orig 2002-09-27 21:18:55.000000000 -0400
++++ speech_tools/config/compilers/gcc32.mak 2002-08-25 18:26:42.000000000 -0400
+@@ -0,0 +1,60 @@
++ ###########################################################################
++ ## ##
++ ## Centre for Speech Technology Research ##
++ ## University of Edinburgh, UK ##
++ ## Copyright (c) 1999 ##
++ ## All Rights Reserved. ##
++ ## ##
++ ## Permission is hereby granted, free of charge, to use and distribute ##
++ ## this software and its documentation without restriction, including ##
++ ## without limitation the rights to use, copy, modify, merge, publish, ##
++ ## distribute, sublicense, and/or sell copies of this work, and to ##
++ ## permit persons to whom this work is furnished to do so, subject to ##
++ ## the following conditions: ##
++ ## 1. The code must retain the above copyright notice, this list of ##
++ ## conditions and the following disclaimer. ##
++ ## 2. Any modifications must be clearly marked as such. ##
++ ## 3. Original authors' names are not deleted. ##
++ ## 4. The authors' names are not used to endorse or promote products ##
++ ## derived from this software without specific prior written ##
++ ## permission. ##
++ ## ##
++ ## THE UNIVERSITY OF EDINBURGH AND THE CONTRIBUTORS TO THIS WORK ##
++ ## DISCLAIM ALL WARRANTIES WITH REGARD TO THIS SOFTWARE, INCLUDING ##
++ ## ALL IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS, IN NO EVENT ##
++ ## SHALL THE UNIVERSITY OF EDINBURGH NOR THE CONTRIBUTORS BE LIABLE ##
++ ## FOR ANY SPECIAL, INDIRECT OR CONSEQUENTIAL DAMAGES OR ANY DAMAGES ##
++ ## WHATSOEVER RESULTING FROM LOSS OF USE, DATA OR PROFITS, WHETHER IN ##
++ ## AN ACTION OF CONTRACT, NEGLIGENCE OR OTHER TORTIOUS ACTION, ##
++ ## ARISING OUT OF OR IN CONNECTION WITH THE USE OR PERFORMANCE OF ##
++ ## THIS SOFTWARE. ##
++ ## ##
++ ###########################################################################
++ ## ##
++ ## Author: Alan W Black (awb@cs.cmu.edu) ##
++ ## Date: Sun Aug 25 2002 ##
++ ## -------------------------------------------------------------------- ##
++ ## Settings for GCC-3.2 ##
++ ## ##
++ ###########################################################################
++
++include $(EST)/config/compilers/gcc_defaults.mak
++
++COMPILER_DESC=gcc-3.2
++
++ifndef GCC32
++ GCC32 = gcc
++endif
++
++CC= $(GCC32)
++CXX = g++
++
++WARN_CXXFLAGS += -Wno-non-template-friend -Wno-deprecated
++
++STATIC_LINKFLAGS = -Dstatic
++
++COMPILERLIBS= $(COMPILER_LIBS_DIR:%=-L%) -lstdc++
++
++
++
++