summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/soundtracker/soundtracker-0.6.4-r1.ebuild')
-rw-r--r--media-sound/soundtracker/soundtracker-0.6.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/soundtracker/soundtracker-0.6.4-r1.ebuild b/media-sound/soundtracker/soundtracker-0.6.4-r1.ebuild
new file mode 100644
index 000000000000..27f61fcbb737
--- /dev/null
+++ b/media-sound/soundtracker/soundtracker-0.6.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Bruce A. Locke <blocke@shivan.org>
+# $Header: /var/cvsroot/gentoo-x86/media-sound/soundtracker/soundtracker-0.6.4-r1.ebuild,v 1.1 2001/10/06 10:08:19 azarah Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="SoundTracker is a music tracking tool for UNIX/X11 (MOD tracker)"
+SRC_URI="http://www.soundtracker.org/dl/v0.6/soundtracker-0.6.4.tar.gz"
+HOMEPAGE="http://www.soundtracker.org"
+
+DEPEND=">=x11-libs/gtk+-1.2.10-r4
+ >=media-libs/audiofile-0.2.1 \
+ alsa? ( media-libs/alsa-lib ) \
+ esd? ( media-sound/esound ) \
+ gnome? ( >=gnome-base/gnome-core-1.4.0.4-r1 ) \
+ sys-libs/zlib"
+
+RDEPEND="$DEPEND sys-apps/bzip2 sys-apps/gzip app-arch/unzip"
+
+src_compile() {
+
+ local myconf
+
+ if [ -z "`use oss`" ] ; then
+ myconf="--disable-oss"
+ fi
+
+ if [ -z "`use alsa`" ] ; then
+ myconf="$myconf --disable-alsa"
+ fi
+
+ if [ -z "`use esd`" ] ; then
+ myconf="$myconf --disable-esd"
+ fi
+
+ if [ -z "`use gnome`" ] ; then
+ myconf="$myconf --disable-gnome"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="$myconf --disable-nls"
+ fi
+
+ try ./configure ${myconf} --infodir=/usr/share/info --mandir=/usr/share/man --prefix=/usr --host=${CHOST} || die
+
+ emake || die
+
+}
+
+src_install () {
+
+ make prefix=${D}/usr install || die
+
+ # strip suid from binary
+ chmod -s ${D}/usr/bin/soundtracker
+
+ # documentation
+ dodoc AUTHORS COPYING ChangeLog FAQ INSTALL NEWS README TODO
+ dodoc doc/*.txt doc/hacking.html
+
+}
+