summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound')
-rw-r--r--media-sound/streamripper/ChangeLog8
-rw-r--r--media-sound/streamripper/streamripper-1.64.6.ebuild34
2 files changed, 41 insertions, 1 deletions
diff --git a/media-sound/streamripper/ChangeLog b/media-sound/streamripper/ChangeLog
index 09ceb53f9e73..1ce8a411d92f 100644
--- a/media-sound/streamripper/ChangeLog
+++ b/media-sound/streamripper/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for media-sound/streamripper
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.66 2010/01/07 14:52:14 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/ChangeLog,v 1.67 2010/03/12 09:37:30 ssuominen Exp $
+
+*streamripper-1.64.6 (12 Mar 2010)
+
+ 12 Mar 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +streamripper-1.64.6.ebuild:
+ Version bump wrt #308427 by Niels Ole Salscheider.
07 Jan 2010; Christian Faulhammer <fauli@gentoo.org>
streamripper-1.64.0.ebuild:
diff --git a/media-sound/streamripper/streamripper-1.64.6.ebuild b/media-sound/streamripper/streamripper-1.64.6.ebuild
new file mode 100644
index 000000000000..287fd49c633b
--- /dev/null
+++ b/media-sound/streamripper/streamripper-1.64.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/streamripper/streamripper-1.64.6.ebuild,v 1.1 2010/03/12 09:37:30 ssuominen Exp $
+
+EAPI=2
+
+DESCRIPTION="Extracts and records individual MP3 file tracks from shoutcast streams"
+HOMEPAGE="http://streamripper.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="vorbis"
+
+RDEPEND="media-libs/libmad
+ media-libs/faad2
+ >=dev-libs/glib-2.16
+ vorbis? ( media-libs/libvorbis )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --without-included-libmad \
+ --without-included-argv \
+ $(use_with vorbis ogg)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc CHANGES parse_rules.txt README THANKS
+}