summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/lives')
-rw-r--r--media-video/lives/ChangeLog6
-rw-r--r--media-video/lives/lives-1.0.0.ebuild60
-rw-r--r--media-video/lives/lives-1.4.2.ebuild58
3 files changed, 5 insertions, 119 deletions
diff --git a/media-video/lives/ChangeLog b/media-video/lives/ChangeLog
index c5c82123e6c7..2106f7838ad0 100644
--- a/media-video/lives/ChangeLog
+++ b/media-video/lives/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for media-video/lives
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lives/ChangeLog,v 1.32 2011/09/30 19:13:53 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/lives/ChangeLog,v 1.33 2011/09/30 19:26:38 ssuominen Exp $
+
+ 30 Sep 2011; Samuli Suominen <ssuominen@gentoo.org> -lives-1.0.0.ebuild,
+ -lives-1.4.2.ebuild:
+ old
*lives-1.4.6 (30 Sep 2011)
diff --git a/media-video/lives/lives-1.0.0.ebuild b/media-video/lives/lives-1.0.0.ebuild
deleted file mode 100644
index e1ecc8c88dc9..000000000000
--- a/media-video/lives/lives-1.0.0.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lives/lives-1.0.0.ebuild,v 1.4 2011/04/04 13:05:26 lu_zero Exp $
-
-EAPI=1
-
-inherit flag-o-matic
-
-MY_P="LiVES-${PV}"
-DESCRIPTION="LiVES is a Video Editing System"
-HOMEPAGE="http://lives.sf.net"
-SRC_URI="http://www.xs4all.nl/~salsaman/lives/current/${MY_P}.tar.bz2"
- # sf.net only has rpms for this version
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="matroska ogg theora libvisual nls" #sdl jack dv"
-
-DEPEND=">=media-video/mplayer-0.90-r2
- >=media-gfx/imagemagick-5.5.6
- >=dev-lang/perl-5.8.0-r12
- >=x11-libs/gtk+-2.2.1:2
- media-libs/libsdl
- virtual/ffmpeg
- virtual/jpeg
- >=media-sound/sox-12.17.3-r3
- virtual/cdrtools
- theora? ( media-libs/libtheora )
- >=dev-lang/python-2.3.4
- matroska? ( media-video/mkvtoolnix
- media-libs/libmatroska )
- ogg? ( media-sound/ogmtools )
- >=media-video/mjpegtools-1.6.2
- libvisual? ( media-libs/libvisual )
- media-sound/jack-audio-connection-kit
- sys-libs/libavc1394"
-RDEPEND="${DEPEND}"
-
-src_unpack() {
- unpack ${A}
- # hardcoding -03 is wrong!
- sed -i -e "s:-O3::g" \
- "${S}"/{,src,lives-plugins,lives-plugins/plugins/playback/video,lives-plugins/weed-plugins}/Makefile*
-}
-
-src_compile() {
- econf \
- $(use_enable libvisual) \
- $(use_enable nls) \
- || die "configure failed"
- emake || die "make failed"
-}
-
-src_install() {
- dodir /usr/share/pixmaps
- dodir /usr/share/applications
- make DESTDIR="${D}" install || die
- dodoc AUTHORS FEATURES GETTING.STARTED
-}
diff --git a/media-video/lives/lives-1.4.2.ebuild b/media-video/lives/lives-1.4.2.ebuild
deleted file mode 100644
index d5dc9445b6b6..000000000000
--- a/media-video/lives/lives-1.4.2.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/lives/lives-1.4.2.ebuild,v 1.1 2011/04/04 13:05:26 lu_zero Exp $
-
-EAPI=2
-
-inherit flag-o-matic
-
-MY_P="LiVES-${PV}"
-DESCRIPTION="LiVES is a Video Editing System"
-HOMEPAGE="http://lives.sf.net"
-SRC_URI="http://www.xs4all.nl/~salsaman/lives/current/${MY_P}.tar.bz2"
- # sf.net only has rpms for this version
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="matroska ogg theora libvisual nls" #sdl jack dv"
-
-DEPEND=">=media-video/mplayer-0.90-r2
- >=media-gfx/imagemagick-5.5.6
- >=dev-lang/perl-5.8.0-r12
- >=x11-libs/gtk+-2.2.1:2
- media-libs/libsdl
- virtual/ffmpeg
- virtual/jpeg
- >=media-sound/sox-12.17.3-r3
- virtual/cdrtools
- theora? ( media-libs/libtheora )
- >=dev-lang/python-2.3.4
- matroska? ( media-video/mkvtoolnix
- media-libs/libmatroska )
- ogg? ( media-sound/ogmtools )
- >=media-video/mjpegtools-1.6.2
- libvisual? ( media-libs/libvisual )
- media-sound/jack-audio-connection-kit
- sys-libs/libavc1394"
-RDEPEND="${DEPEND}"
-
-src_prepare() {
- # hardcoding -03 is wrong!
- sed -i -e "s:-O3::g" \
- "${S}"/{libweed,lives-plugins/{plugins/{decoders,playback/video},weed-plugins{,/gdk}},src}/Makefile.* || die
-}
-
-src_configure() {
- econf \
- $(use_enable libvisual) \
- $(use_enable nls) \
- || die "configure failed"
-}
-
-src_install() {
- dodir /usr/share/pixmaps
- dodir /usr/share/applications
- make DESTDIR="${D}" install || die
- dodoc AUTHORS FEATURES GETTING.STARTED
-}