summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video/rtmpdump')
-rw-r--r--media-video/rtmpdump/ChangeLog5
-rw-r--r--media-video/rtmpdump/rtmpdump-2.3.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/media-video/rtmpdump/ChangeLog b/media-video/rtmpdump/ChangeLog
index 7af35b063ce5..dadb5bef7729 100644
--- a/media-video/rtmpdump/ChangeLog
+++ b/media-video/rtmpdump/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-video/rtmpdump
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.7 2010/07/07 22:25:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/ChangeLog,v 1.8 2010/07/08 10:02:30 hwoarang Exp $
+
+ 08 Jul 2010; Markos Chandras <hwoarang@gentoo.org> rtmpdump-2.3.ebuild:
+ Fix multilib-strict support. Bug #327449
*rtmpdump-2.3 (07 Jul 2010)
diff --git a/media-video/rtmpdump/rtmpdump-2.3.ebuild b/media-video/rtmpdump/rtmpdump-2.3.ebuild
index 40f6b73b678f..a47e7f12d11c 100644
--- a/media-video/rtmpdump/rtmpdump-2.3.ebuild
+++ b/media-video/rtmpdump/rtmpdump-2.3.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.3.ebuild,v 1.1 2010/07/07 22:25:30 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/rtmpdump/rtmpdump-2.3.ebuild,v 1.2 2010/07/08 10:02:30 hwoarang Exp $
EAPI="2"
-inherit toolchain-funcs
+inherit multilib toolchain-funcs
DESCRIPTION="Open source command-line RTMP client intended to stream audio or video flash content"
HOMEPAGE="http://rtmpdump.mplayerhq.hu/"
@@ -50,13 +50,14 @@ src_compile() {
crypto="OPENSSL"
fi
fi
-
+ #fix multilib-script support. Bug #327449
+ sed -i "/^libdir/s:lib$:$(get_libdir)$:" librtmp/Makefile
emake CC=$(tc-getCC) LD=$(tc-getLD) \
OPT="${CFLAGS}" XLDFLAGS="${LDFLAGS}" CRYPTO="${crypto}" SYS=posix || die "emake failed"
}
src_install() {
- mkdir -p "${D}"/${DESTTREE}/lib
+ mkdir -p "${D}"/${DESTTREE}/$(get_libdir)
emake DESTDIR="${D}" prefix="${DESTTREE}" mandir="${DESTTREE}/share/man" \
CRYPTO="${crypto}" install || die "emake install failed"
dodoc README ChangeLog rtmpdump.1.html rtmpgw.8.html || die "dodoc failed"