summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/cacti')
-rw-r--r--net-analyzer/cacti/ChangeLog9
-rw-r--r--net-analyzer/cacti/cacti-0.8.5.ebuild124
-rw-r--r--net-analyzer/cacti/files/digest-cacti-0.8.51
3 files changed, 132 insertions, 2 deletions
diff --git a/net-analyzer/cacti/ChangeLog b/net-analyzer/cacti/ChangeLog
index 2fd01c51007a..ced590c600eb 100644
--- a/net-analyzer/cacti/ChangeLog
+++ b/net-analyzer/cacti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-analyzer/cacti
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.19 2003/12/15 20:19:30 stuart Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/ChangeLog,v 1.20 2004/02/29 08:39:55 mholzer Exp $
+
+*cacti-0.8.5 (29 Feb 2004)
+
+ 29 Feb 2004; Martin Holzer <mholzer@gentoo.org> cacti-0.8.5.ebuild:
+ Version bumped. Closes 43137.
15 Dec 2003; Stuart Herbert <stuart@gentoo.org> cacti-0.8.3a.ebuild,
cacti-0.8.4.ebuild:
diff --git a/net-analyzer/cacti/cacti-0.8.5.ebuild b/net-analyzer/cacti/cacti-0.8.5.ebuild
new file mode 100644
index 000000000000..771922628e76
--- /dev/null
+++ b/net-analyzer/cacti/cacti-0.8.5.ebuild
@@ -0,0 +1,124 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti/cacti-0.8.5.ebuild,v 1.1 2004/02/29 08:39:55 mholzer Exp $
+
+inherit eutils webapp-apache
+
+DESCRIPTION="Cacti is a complete frondend to rrdtool"
+HOMEPAGE="http://www.raxnet.net/products/cacti/"
+SRC_URI="http://www.raxnet.net/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+IUSE="snmp mysql"
+
+DEPEND=""
+RDEPEND="net-www/apache
+ snmp? ( virtual/snmp )
+ net-analyzer/rrdtool
+ mysql? ( dev-db/mysql )
+ dev-php/php
+ dev-php/mod_php"
+
+webapp-detect || NO_WEBSERVER=1
+
+pkg_setup() {
+ webapp-pkg_setup "${NO_WEBSERVER}"
+ einfo "Installing into ${ROOT}${HTTPD_ROOT}."
+}
+
+src_install() {
+ webapp-mkdirs
+
+ local DocumentRoot=${HTTPD_ROOT}
+ local destdir=${DocumentRoot}/${PN}
+ dodir ${destdir}
+
+ dohtml docs/{INSTALL,UPGRADE}.htm
+ dodoc docs/{CHANGELOG,CONTRIB}
+ dodoc LICENSE
+
+ rm docs/{INSTALL,UPGRADE,INSTALL-WIN32}.htm
+ rm docs/{README,CHANGELOG,CONTRIB}
+ rm LICENSE README
+
+ mv docs/manual .
+ rm -fr docs
+ rm -rf cactid
+
+ edos2unix `find -type f -name '*.php'`
+ #chown -R ${HTTPD_USER}.${HTTPD_GROUP} *
+ cp -r . ${D}/${HTTPD_ROOT}/${PN}
+ cd ${D}/${HTTPD_ROOT}
+ chown -R ${HTTPD_USER}:${HTTPD_GROUP} ${PN}
+}
+
+pkg_postinst() {
+ # check to see if we have a previous version installed
+ minor_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f2)"
+ rel_inst="$(ls -d /var/db/pkg/net-analyzer/cacti*|head -n 1|cut -d\. -f3)"
+ if [ ${minor_inst}${rel_inst} -lt 81 ]
+ then
+ einfo
+ einfo "The cacti has been installed to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must upgrade the cacti database:"
+ einfo "1. Backup the old cacti database:"
+ einfo " shell> mysqlhotcopy --suffix=_old cacti"
+ einfo "2. Drop the old cacti database:"
+ einfo " shell> mysqladmin -p drop cacti"
+ einfo "3. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "4. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "5. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "6. Point your web browser to: http://your-server/cacti/"
+ einfo " Select \"Upgrade\"."
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ einfo "Test your upgraded installation. When all is fine you can"
+ eingo "drop the cacti_old database like so:"
+ einfo " shell> mysqladmin -p drop cacti_old"
+ einfo
+ else
+ einfo
+ einfo "The cacti has been copied to ${INSTALL_DEST}"
+ einfo
+ einfo "Before cacti works you must:"
+ einfo "1. Create the new cacti database"
+ einfo " shell> mysqladmin --user=root create cacti"
+ einfo "2. Import the default cacti database:"
+ einfo " shell> mysql cacti < ${INSTALL_DEST}/cacti.sql"
+ einfo "3. Optional: Create a MySQL username and password for cacti."
+ einfo " shell> mysql --user=root mysql"
+ einfo " mysql> GRANT ALL ON cacti.* TO cactiuser@localhost IDENTIFIED BY 'somepassword';"
+ einfo " mysql> flush privileges;"
+ einfo "4. Edit ${INSTALL_DEST}/include/config.php."
+ einfo " + Modify the MySQL user, password and database for your"
+ einfo " cacti configuration."
+ einfo " \$database_default = \"cacti\";"
+ einfo " \$database_hostname = \"localhost\";"
+ einfo " \$database_username = \"cactiuser\";"
+ einfo " \$database_password = \"cacti\";"
+ einfo "5. Point your web browser to: http://your-server/cacti/"
+ einfo " Make sure to fill in all of the path variables carefully and"
+ einfo " correctly on the following screen."
+ einfo
+ einfo "FINALLY, you must have these settings in your php.ini:"
+ einfo " register_globals = On"
+ einfo " register_argc_argv = On"
+ einfo
+ fi
+}
diff --git a/net-analyzer/cacti/files/digest-cacti-0.8.5 b/net-analyzer/cacti/files/digest-cacti-0.8.5
new file mode 100644
index 000000000000..27bcc475f21d
--- /dev/null
+++ b/net-analyzer/cacti/files/digest-cacti-0.8.5
@@ -0,0 +1 @@
+MD5 72d5710d404d7d2d9ab8f14ee19f91ea cacti-0.8.5.tar.gz 982734