summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/p0f/p0f-2.0.2.ebuild')
-rw-r--r--net-analyzer/p0f/p0f-2.0.2.ebuild12
1 files changed, 9 insertions, 3 deletions
diff --git a/net-analyzer/p0f/p0f-2.0.2.ebuild b/net-analyzer/p0f/p0f-2.0.2.ebuild
index a482c8521d38..3a0cb9470a8b 100644
--- a/net-analyzer/p0f/p0f-2.0.2.ebuild
+++ b/net-analyzer/p0f/p0f-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.2.ebuild,v 1.1 2003/10/03 23:57:42 pappy Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.2.ebuild,v 1.2 2003/10/04 10:46:13 pappy Exp $
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
SRC_URI="http://lcamtuf.coredump.cx/p0f.tgz"
@@ -11,12 +11,18 @@ KEYWORDS="~x86"
DEPEND="net-libs/libpcap"
-src_compile() {
+src_compile () {
cd ${WORKDIR}/p0f
+ sed -i "s: /usr/sbin/: ../../image/usr/sbin/:g" ${WORKDIR}/p0f/mk/Linux
+ sed -i "s: /etc/p0f: ../../image/etc/p0f:g" ${WORKDIR}/p0f/mk/Linux
+ sed -i "s: /usr/man/man1/: ../../image/usr/man/man1/:g" ${WORKDIR}/p0f/mk/Linux
make || die
}
src_install () {
cd ${WORKDIR}/p0f
- make DESTDIR=${D} install || die
+ dodir /usr/sbin; dodir /etc/p0f; dodir /usr/man/man1
+ mkdir -p ../../image/usr/sbin ../../image/etc/p0f ../../image/usr/man/man1
+ make install || die
}
+