summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/p0f')
-rw-r--r--net-analyzer/p0f/ChangeLog6
-rw-r--r--net-analyzer/p0f/metadata.xml6
-rw-r--r--net-analyzer/p0f/p0f-1.8.2.ebuild9
-rw-r--r--net-analyzer/p0f/p0f-2.0.2.ebuild4
-rw-r--r--net-analyzer/p0f/p0f-2.0.3.ebuild4
5 files changed, 21 insertions, 8 deletions
diff --git a/net-analyzer/p0f/ChangeLog b/net-analyzer/p0f/ChangeLog
index 3a2610f50c54..06f6bdeb5107 100644
--- a/net-analyzer/p0f/ChangeLog
+++ b/net-analyzer/p0f/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-analyzer/p0f
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.12 2004/06/24 22:14:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/ChangeLog,v 1.13 2004/07/11 10:33:31 eldad Exp $
+
+ 11 Jul 2004; Eldad Zack <eldad@gentoo.org> +metadata.xml, p0f-1.8.2.ebuild,
+ p0f-2.0.2.ebuild, p0f-2.0.3.ebuild:
+ Updated to use epatch. marked x86 stable.
27 Apr 2004; Aron Griffis <agriffis@gentoo.org> p0f-2.0.3.ebuild:
Add inherit eutils
diff --git a/net-analyzer/p0f/metadata.xml b/net-analyzer/p0f/metadata.xml
new file mode 100644
index 000000000000..44b3cbf45583
--- /dev/null
+++ b/net-analyzer/p0f/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<longdescription>p0f performs passive OS detection based on SYN packets.</longdescription>
+</pkgmetadata>
diff --git a/net-analyzer/p0f/p0f-1.8.2.ebuild b/net-analyzer/p0f/p0f-1.8.2.ebuild
index 6900e74f8adf..6189549a5461 100644
--- a/net-analyzer/p0f/p0f-1.8.2.ebuild
+++ b/net-analyzer/p0f/p0f-1.8.2.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.13 2004/06/24 22:14:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-1.8.2.ebuild,v 1.14 2004/07/11 10:33:31 eldad Exp $
+
+inherit eutils
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
SRC_URI="http://www.stearns.org/p0f/p0f-1.8.2.tgz"
@@ -8,12 +10,13 @@ HOMEPAGE="http://www.stearns.org/p0f/"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="x86 sparc "
+KEYWORDS="x86 sparc"
+IUSE=""
DEPEND="net-libs/libpcap"
src_compile() {
- patch < ${FILESDIR}/${P}-makefile.patch
+ epatch ${FILESDIR}/${P}-makefile.patch
cp ${FILESDIR}/${P}.rc p0f.rc
make || die
}
diff --git a/net-analyzer/p0f/p0f-2.0.2.ebuild b/net-analyzer/p0f/p0f-2.0.2.ebuild
index eb25ae8187e1..2d19a6f84311 100644
--- a/net-analyzer/p0f/p0f-2.0.2.ebuild
+++ b/net-analyzer/p0f/p0f-2.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.2.ebuild,v 1.5 2004/06/24 22:14:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.2.ebuild,v 1.6 2004/07/11 10:33:31 eldad Exp $
DESCRIPTION="p0f performs passive OS detection based on SYN packets."
# the p0f.tgz always resembles the latest version, trashing the digest md5sum then, discovered and fixed by gustavoz
@@ -8,7 +8,7 @@ SRC_URI="http://lcamtuf.coredump.cx/p0f/${P}.tgz"
HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="~x86"
+KEYWORDS="x86"
IUSE=""
DEPEND="net-libs/libpcap"
diff --git a/net-analyzer/p0f/p0f-2.0.3.ebuild b/net-analyzer/p0f/p0f-2.0.3.ebuild
index d715775e9d68..4cd6aba5cc7a 100644
--- a/net-analyzer/p0f/p0f-2.0.3.ebuild
+++ b/net-analyzer/p0f/p0f-2.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.3.ebuild,v 1.3 2004/06/24 22:14:38 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/p0f/p0f-2.0.3.ebuild,v 1.4 2004/07/11 10:33:31 eldad Exp $
inherit eutils
@@ -10,7 +10,7 @@ SRC_URI="http://lcamtuf.coredump.cx/p0f/${P}.tgz"
HOMEPAGE="http://lcamtuf.coredump.cx/p0f.shtml"
SLOT="0"
LICENSE="LGPL-2.1"
-KEYWORDS="~x86 ~amd64"
+KEYWORDS="x86 ~amd64"
IUSE=""
S=${WORKDIR}/${PN}