summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/traceproto/traceproto-1.1.1.ebuild')
-rw-r--r--net-analyzer/traceproto/traceproto-1.1.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-analyzer/traceproto/traceproto-1.1.1.ebuild b/net-analyzer/traceproto/traceproto-1.1.1.ebuild
new file mode 100644
index 000000000000..e7b298b1a5cb
--- /dev/null
+++ b/net-analyzer/traceproto/traceproto-1.1.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/traceproto/traceproto-1.1.1.ebuild,v 1.1 2005/01/31 10:39:56 ka0ttic Exp $
+
+inherit eutils
+
+DESCRIPTION="A traceroute-like utility that sends packets based on protocol"
+HOMEPAGE="http://traceproto.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="debug ncurses"
+
+RDEPEND=">=net-libs/libnet-1.1.0
+ virtual/libpcap
+ ncurses? ( sys-libs/ncurses )
+ debug? ( dev-libs/dmalloc )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${P}-fix-warnings.diff
+}
+
+src_compile() {
+ local myconf
+ use debug && myconf="--enable-dmalloc"
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO INSTALL
+}