summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch')
-rw-r--r--net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch51
1 files changed, 0 insertions, 51 deletions
diff --git a/net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch b/net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch
deleted file mode 100644
index c2359d9bf15d..000000000000
--- a/net-dialup/pptpd/files/pptpd-1.3.2-gentoo.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff -Nru pptpd-1.3.2.orig/Makefile.am pptpd-1.3.2/Makefile.am
---- pptpd-1.3.2.orig/Makefile.am 2006-04-18 06:22:17.000000000 +0300
-+++ pptpd-1.3.2/Makefile.am 2006-05-13 00:01:40.666690750 +0300
-@@ -11,7 +11,7 @@
- ## warning with -Wmissing-prototypes).
- ## -Wmissing-prototypes removed (eg, Linux 2.2.6 headers
- ## aren't up to it).
--CFLAGS = -O2 -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
-+CFLAGS += -fno-builtin -Wall -DSBINDIR='"$(sbindir)"'
- #CFLAGS = -O2 -fno-builtin -Wall -ansi -DSBINDIR='"$(sbindir)"'
- #CFLAGS = -O2 -fno-builtin -Wall -ansi -pedantic -Wmissing-prototypes -Werror -DSBINDIR='"$(sbindir)"'
-
-diff -Nru pptpd-1.3.2.orig/plugins/Makefile pptpd-1.3.2/plugins/Makefile
---- pptpd-1.3.2.orig/plugins/Makefile 2004-05-21 12:26:37.000000000 +0300
-+++ pptpd-1.3.2/plugins/Makefile 2006-05-13 00:01:40.666690750 +0300
-@@ -1,6 +1,5 @@
- CC = gcc
--COPTS = -O2 -g
--CFLAGS = $(COPTS) -I.. -I../../include -fPIC
-+CFLAGS += -I.. -I../../include -fPIC
- LDFLAGS = -shared
- INSTALL = install -o root
- prefix = /usr/local
-diff -Nru pptpd-1.3.2.orig/pptpgre.c pptpd-1.3.2/pptpgre.c
---- pptpd-1.3.2.orig/pptpgre.c 2006-03-28 00:39:05.000000000 +0300
-+++ pptpd-1.3.2/pptpgre.c 2006-05-13 00:05:12.462064250 +0300
-@@ -405,9 +405,9 @@
- }
- /* check for out-of-order sequence number */
- if (seq_greater(seq, gre.seq_recv)) {
-- if (pptpctrl_debug)
-+ /* if (pptpctrl_debug)
- syslog(LOG_DEBUG, "GRE: accepting packet #%d",
-- seq);
-+ seq); */
- stats.rx_accepted++;
- gre.seq_recv = seq;
- return cb(cl, buffer + ip_len + headersize, payload_len);
-diff -Nru pptpd-1.3.2.orig/pqueue.c pptpd-1.3.2/pqueue.c
---- pptpd-1.3.2.orig/pqueue.c 2005-08-03 11:53:22.000000000 +0300
-+++ pptpd-1.3.2/pqueue.c 2006-05-13 00:01:40.666690750 +0300
-@@ -12,7 +12,8 @@
- #define DEBUG_ON 0
- #endif
-
--#define DEBUG_CMD(_a) if (DEBUG_ON) { _a }
-+/* #define DEBUG_CMD(_a) if (DEBUG_ON) { _a } */
-+#define DEBUG_CMD(_a)
-
- #define MIN_CAPACITY 128 /* min allocated buffer for a packet */
-