summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/dnsmasq/dnsmasq-2.16.ebuild')
-rw-r--r--net-dns/dnsmasq/dnsmasq-2.16.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-dns/dnsmasq/dnsmasq-2.16.ebuild b/net-dns/dnsmasq/dnsmasq-2.16.ebuild
new file mode 100644
index 000000000000..42eeaaf40135
--- /dev/null
+++ b/net-dns/dnsmasq/dnsmasq-2.16.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dns/dnsmasq/dnsmasq-2.16.ebuild,v 1.1 2004/10/22 17:33:25 avenj Exp $
+
+MY_P="${P/_/}"
+MY_PV="${PV/_rc*/}"
+DESCRIPTION="Small forwarding DNS server"
+HOMEPAGE="http://www.thekelleys.org.uk/dnsmasq/"
+SRC_URI="http://www.thekelleys.org.uk/dnsmasq/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~mips ~arm ~amd64 ~ia64 ~s390"
+IUSE=""
+
+DEPEND="virtual/libc
+ >=sys-apps/sed-4"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_compile() {
+ emake || die
+}
+
+src_install() {
+ make \
+ PREFIX=/usr \
+ MANDIR=/usr/share/man \
+ DESTDIR=${D} \
+ install || die
+ dodoc CHANGELOG FAQ
+ dohtml *.html
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/dnsmasq-init dnsmasq
+ insinto /etc/conf.d
+ newins ${FILESDIR}/dnsmasq.confd dnsmasq
+ insinto /etc
+ newins dnsmasq.conf.example dnsmasq.conf
+}