summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/iptables/ChangeLog7
-rw-r--r--net-firewall/iptables/iptables-1.4.9.1.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/net-firewall/iptables/ChangeLog b/net-firewall/iptables/ChangeLog
index 7410ceb7af24..14391f71d21a 100644
--- a/net-firewall/iptables/ChangeLog
+++ b/net-firewall/iptables/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-firewall/iptables
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.219 2010/08/03 22:10:28 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/ChangeLog,v 1.220 2010/08/09 08:01:56 pva Exp $
+
+*iptables-1.4.9.1 (09 Aug 2010)
+
+ 09 Aug 2010; Peter Volkov <pva@gentoo.org> +iptables-1.4.9.1.ebuild:
+ Version bump. Release for kernel 2.6.35.
03 Aug 2010; Guy Martin <gmsoft@gentoo.org> iptables-1.4.6.ebuild:
hppa stable wrt #318531
diff --git a/net-firewall/iptables/iptables-1.4.9.1.ebuild b/net-firewall/iptables/iptables-1.4.9.1.ebuild
new file mode 100644
index 000000000000..77bd10391291
--- /dev/null
+++ b/net-firewall/iptables/iptables-1.4.9.1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-firewall/iptables/iptables-1.4.9.1.ebuild,v 1.1 2010/08/09 08:01:56 pva Exp $
+
+EAPI="2"
+inherit eutils toolchain-funcs autotools
+
+DESCRIPTION="Linux kernel (2.4+) firewall, NAT and packet mangling tools"
+HOMEPAGE="http://www.iptables.org/"
+SRC_URI="http://iptables.org/projects/iptables/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ipv6"
+
+DEPEND="virtual/os-headers"
+RDEPEND=""
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sbindir=/sbin \
+ --libexecdir=/$(get_libdir) \
+ --enable-devel \
+ --enable-libipq \
+ --enable-shared \
+ --enable-static \
+ $(use_enable ipv6)
+}
+
+src_compile() {
+ emake V=1 || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dosbin iptables-apply || die
+ doman iptables-apply.8 || die
+ dodoc INCOMPATIBILITIES iptables.xslt || die
+
+ insinto /usr/include
+ doins include/iptables.h $(use ipv6 && echo include/ip6tables.h) || die
+ insinto /usr/include/iptables
+ doins include/iptables/internal.h || die
+
+ keepdir /var/lib/iptables
+ newinitd "${FILESDIR}"/${PN}-1.3.2.init iptables || die
+ newconfd "${FILESDIR}"/${PN}-1.3.2.confd iptables || die
+ if use ipv6 ; then
+ keepdir /var/lib/ip6tables
+ newinitd "${FILESDIR}"/iptables-1.3.2.init ip6tables || die
+ newconfd "${FILESDIR}"/ip6tables-1.3.2.confd ip6tables || die
+ fi
+}